summaryrefslogtreecommitdiffstats
path: root/openwrt/package/sdk
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-12-12 00:08:08 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-12-12 00:08:08 +0000
commit7591ac44ef6456af2f6730feda41370b22667b9b (patch)
tree627cb78c334cceaa79b2606be8c7b2e057a25a89 /openwrt/package/sdk
parenta19d85c1cffd375c50cf701a00962f9383d9415e (diff)
build package index in sdk (fixes #51)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@2629 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/sdk')
-rw-r--r--openwrt/package/sdk/files/Makefile.sdk8
1 files changed, 7 insertions, 1 deletions
diff --git a/openwrt/package/sdk/files/Makefile.sdk b/openwrt/package/sdk/files/Makefile.sdk
index b4a3010be..6d5f61ad1 100644
--- a/openwrt/package/sdk/files/Makefile.sdk
+++ b/openwrt/package/sdk/files/Makefile.sdk
@@ -12,7 +12,7 @@ PACKAGES_PREPARE:=$(foreach package,$(PACKAGES),$(package)-prepare)
PACKAGES_COMPILE:=$(foreach package,$(PACKAGES),$(package)-compile)
PACKAGES_CLEAN:=$(foreach package,$(PACKAGES),$(package)-clean)
-all: compile
+all: compile package_index
compile: $(PACKAGES_COMPILE)
clean: $(PACKAGES_CLEAN)
rm -rf $(BUILD_DIR)
@@ -34,3 +34,9 @@ distclean: clean
$(BUILD_DIR):
mkdir -p $@
mkdir -p $(DL_DIR)
+
+package_index:
+ (cd $(PACKAGE_DIR); \
+ $(STAGING_DIR)/usr/bin/ipkg-make-index . > Packages \
+ )
+