summaryrefslogtreecommitdiffstats
path: root/openwrt/package/ppp/Makefile
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-07-03 18:02:34 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-07-03 18:02:34 +0000
commit651212067733fbe278ea227f84b5180fd0deded9 (patch)
tree5e9ace3eceabdc6caec739df481d0555e8c83dbe /openwrt/package/ppp/Makefile
parenteac0111497d7e9e29aab03a3ff8edeb367214f1c (diff)
remove pppoe init script, add ifup.pppoe for that
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1325 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/ppp/Makefile')
-rw-r--r--openwrt/package/ppp/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/openwrt/package/ppp/Makefile b/openwrt/package/ppp/Makefile
index e1c3907ce..1b95a76c7 100644
--- a/openwrt/package/ppp/Makefile
+++ b/openwrt/package/ppp/Makefile
@@ -70,6 +70,7 @@ $(PKG_BUILD_DIR)/.built:
$(MAKE) -C $(PKG_BUILD_DIR) \
CC=$(TARGET_CC) \
COPTS="$(TARGET_CFLAGS)" \
+ HAVE_INET6="1" \
DESTDIR="$(PKG_INSTALL_DIR)/usr" \
all install
touch $@
@@ -88,8 +89,8 @@ $(IPKG_PPP):
$(IPKG_BUILD) $(IDIR_PPP) $(PACKAGE_DIR)
$(IDIR_PPP_MOD_PPPOE)/etc/init.d/S50pppoe:
- install -d -m0755 $(IDIR_PPP_MOD_PPPOE)/etc/init.d
- install -m0755 ./files/pppoe.init $(IDIR_PPP_MOD_PPPOE)/etc/init.d/S50pppoe
+ install -d -m0755 $(IDIR_PPP_MOD_PPPOE)/sbin
+ install -m0755 ./files/ifup.pppoe $(IDIR_PPP_MOD_PPPOE)/sbin/
$(IPKG_PPP_MOD_PPPOE): $(IDIR_PPP_MOD_PPPOE)/etc/init.d/S50pppoe