summaryrefslogtreecommitdiffstats
path: root/openwrt/package/postgresql/Makefile
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-04-28 21:21:38 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-04-28 21:21:38 +0000
commit02f7e55cbd90f99ff5a0f99bfbe2eeb12311bf21 (patch)
tree0e82f6e0709c24133b1268773ebe0feec3a9fedc /openwrt/package/postgresql/Makefile
parent99487379fe396c29e357b588763c1a35d9daaa26 (diff)
update postgresql and fix gcc 3.4 build
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@748 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/postgresql/Makefile')
-rw-r--r--openwrt/package/postgresql/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/openwrt/package/postgresql/Makefile b/openwrt/package/postgresql/Makefile
index 12fbde500..592d4cc34 100644
--- a/openwrt/package/postgresql/Makefile
+++ b/openwrt/package/postgresql/Makefile
@@ -3,9 +3,9 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=postgresql
-PKG_VERSION:=7.4.6
+PKG_VERSION:=7.4.7
PKG_RELEASE:=3
-PKG_MD5SUM:=f0ea2b372a7bdaf2613e92176ebf5e0f
+PKG_MD5SUM:=32dac2916d16287d95e0c958a75161fa
PKG_SOURCE_URL:=\
ftp://ftp3.us.postgresql.org/pub/postgresql/source/v$(PKG_VERSION)/ \
@@ -22,6 +22,11 @@ IPKG_LIBPQ:=$(PACKAGE_DIR)/libpq_$(PKG_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
IDIR_LIBPQ:=$(PKG_BUILD_DIR)/ipkg
INFO_LIBPQ:=$(IPKG_STATE_DIR)/info/libpq.list
+EXTRA_CFLAGS:=
+ifeq ($(BR2_GCC_3_4),y)
+ EXTRA_CFLAGS += -fno-unit-at-a-time
+endif
+
$(DL_DIR)/$(PKG_SOURCE):
$(SCRIPT_DIR)/download.pl $(DL_DIR) $(PKG_SOURCE) $(PKG_MD5SUM) $(PKG_SOURCE_URL)
@@ -34,7 +39,7 @@ $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
# ./configure advertise "--infodir", but does not support it, replaced with "--docdir"
(cd $(PKG_BUILD_DIR); rm -rf config.cache config.status; \
$(TARGET_CONFIGURE_OPTS) \
- CFLAGS="$(TARGET_CFLAGS)" \
+ CFLAGS="$(TARGET_CFLAGS) $(EXTRA_CFLAGS)" \
CPPFLAGS="$$CPPFLAGS -I$(STAGING_DIR)/usr/include" \
LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
./configure \