summaryrefslogtreecommitdiffstats
path: root/openwrt/package/osiris
diff options
context:
space:
mode:
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-05-19 21:14:18 +0000
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-05-19 21:14:18 +0000
commita30fc45109b8f41d789036bdd9cc1ed9125ed2f8 (patch)
treeb8351969b1dadbaabafe43482b81fc9ec7aaabaa /openwrt/package/osiris
parent29dc4733187277b90e3671e5443eb620b75740fd (diff)
Tweak package build
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@968 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/osiris')
-rw-r--r--openwrt/package/osiris/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/openwrt/package/osiris/Makefile b/openwrt/package/osiris/Makefile
index ca7056dd6..b119f6e03 100644
--- a/openwrt/package/osiris/Makefile
+++ b/openwrt/package/osiris/Makefile
@@ -50,16 +50,16 @@ $(PKG_BUILD_DIR)/.configured:
--with-osiris-user=root \
--with-root-dir=/var/lib/osiris \
);
- touch $(PKG_BUILD_DIR)/.configured
+ touch $@
$(PKG_BUILD_DIR)/.built:
- $(MAKE) -C $(PKG_BUILD_DIR)
+ rm -rf $(PKG_INSTALL_DIR)
mkdir -p $(PKG_INSTALL_DIR)
$(MAKE) -C $(PKG_BUILD_DIR) \
DESTDIR="$(PKG_INSTALL_DIR)" \
INTERACTIVE=0 \
- install
- touch $(PKG_BUILD_DIR)/.built
+ all install
+ touch $@
$(IPKG_OSIRISD):
install -d -m0755 $(IDIR_OSIRISD)/etc/init.d