summaryrefslogtreecommitdiffstats
path: root/openwrt/package/openswan/Makefile
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-11-07 17:48:48 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-11-07 17:48:48 +0000
commit482e137e98c6781c276b0628cc67cc046db90074 (patch)
treecaf443fd93be8471c4350f21cbb330e5d5267f0f /openwrt/package/openswan/Makefile
parente3fd8663f100fe33dcda1f0bbf46bb1ab3338436 (diff)
fix openswan rebuild
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@2377 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/openswan/Makefile')
-rw-r--r--openwrt/package/openswan/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/openwrt/package/openswan/Makefile b/openwrt/package/openswan/Makefile
index a25f12d37..db175f27a 100644
--- a/openwrt/package/openswan/Makefile
+++ b/openwrt/package/openswan/Makefile
@@ -18,6 +18,9 @@ $(eval $(call PKG_template,OPENSWAN,openswan,$(PKG_VERSION)-$(PKG_RELEASE),$(ARC
FLAGS := $(TARGET_CFLAGS) -I$(PKG_BUILD_DIR)/linux/include -L$(STAGING_DIR)/usr/lib -I$(STAGING_DIR)/usr/include
+$(PKG_BUILD_DIR)/.configured:
+ touch $@
+
$(PKG_BUILD_DIR)/.built:
$(MAKE) -C $(PKG_BUILD_DIR) \
$(TARGET_CONFIGURE_OPTS) \
@@ -29,6 +32,7 @@ $(PKG_BUILD_DIR)/.built:
IPSECDIR="/usr/lib/ipsec" \
INC_USRLOCAL="/usr" \
programs
+ touch $@
$(IPKG_OPENSWAN):
$(MAKE) -C $(PKG_BUILD_DIR) \