summaryrefslogtreecommitdiffstats
path: root/openwrt/package/openser/Makefile
diff options
context:
space:
mode:
authormbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-02-01 23:53:19 +0000
committermbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-02-01 23:53:19 +0000
commit475e0d886041b4345585e13f0c04bcb9af0c0c5a (patch)
tree1cee9cdbc46a10aace75d7ad9775d35a13e3c3ff /openwrt/package/openser/Makefile
parent5ef7471191922d05b08e520a05f4a7daeb22754b (diff)
change cp to $(CP)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@3112 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/openser/Makefile')
-rw-r--r--openwrt/package/openser/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/openwrt/package/openser/Makefile b/openwrt/package/openser/Makefile
index 29d72864f..d3b482678 100644
--- a/openwrt/package/openser/Makefile
+++ b/openwrt/package/openser/Makefile
@@ -42,17 +42,17 @@ $(PKG_BUILD_DIR)/.built:
$(IPKG_OPENSER):
mkdir -p $(IDIR_OPENSER)/usr/sbin
- cp -fpR $(PKG_BUILD_DIR)/$(PKG_NAME) $(IDIR_OPENSER)/usr/sbin/
- cp -fpR $(PKG_BUILD_DIR)/utils/gen_ha1/gen_ha1 $(IDIR_OPENSER)/usr/sbin/openser_gen_ha1
- cp -fpR $(PKG_BUILD_DIR)/scripts/sc $(IDIR_OPENSER)/usr/sbin/openserctl
+ $(CP) $(PKG_BUILD_DIR)/$(PKG_NAME) $(IDIR_OPENSER)/usr/sbin/
+ $(CP) $(PKG_BUILD_DIR)/utils/gen_ha1/gen_ha1 $(IDIR_OPENSER)/usr/sbin/openser_gen_ha1
+ $(CP) $(PKG_BUILD_DIR)/scripts/sc $(IDIR_OPENSER)/usr/sbin/openserctl
chmod 744 $(IDIR_OPENSER)/usr/sbin/openserctl
- cp -fpR $(PKG_BUILD_DIR)/scripts/sc.dbtext $(IDIR_OPENSER)/usr/sbin/dbtextctl
+ $(CP) $(PKG_BUILD_DIR)/scripts/sc.dbtext $(IDIR_OPENSER)/usr/sbin/dbtextctl
chmod 744 $(IDIR_OPENSER)/usr/sbin/dbtextctl
mkdir -p $(IDIR_OPENSER)/usr/lib/openser/modules
(cd $(PKG_BUILD_DIR);\
- cp -a $(OPENSER_MODULE_FILES) $(IDIR_OPENSER)/usr/lib/openser/modules/; \
+ $(CP) $(OPENSER_MODULE_FILES) $(IDIR_OPENSER)/usr/lib/openser/modules/; \
)
mkdir -p $(IDIR_OPENSER)/etc/openser
- cp -fpR $(PKG_BUILD_DIR)/etc/openser.cfg $(IDIR_OPENSER)/etc/openser/
+ $(CP) $(PKG_BUILD_DIR)/etc/openser.cfg $(IDIR_OPENSER)/etc/openser/
$(RSTRIP) $(IDIR_OPENSER)
$(IPKG_BUILD) $(IDIR_OPENSER) $(PACKAGE_DIR)