summaryrefslogtreecommitdiffstats
path: root/openwrt/package/openntpd/Makefile
diff options
context:
space:
mode:
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-02-23 15:57:37 +0000
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-02-23 15:57:37 +0000
commit1f2800f5f5534f4d76defa4deefbfff92f2ea944 (patch)
tree19ef23352b0952c31dfdcc1150ab12cb8416871b /openwrt/package/openntpd/Makefile
parent4249bc8ddf7ee8f678b801d23ca13f628e1c40ec (diff)
Updated to 3.7p1 and add support for adjtimex, thanks to Darren Tucker. Closes #320
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@3267 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/openntpd/Makefile')
-rw-r--r--openwrt/package/openntpd/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/openwrt/package/openntpd/Makefile b/openwrt/package/openntpd/Makefile
index 45584a692..64df56af9 100644
--- a/openwrt/package/openntpd/Makefile
+++ b/openwrt/package/openntpd/Makefile
@@ -3,9 +3,9 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=openntpd
-PKG_VERSION:=3.6.1p1
+PKG_VERSION:=3.7p1
PKG_RELEASE:=1
-PKG_MD5SUM:=4584f226523776a3cdd2fb6f8212ba8d
+PKG_MD5SUM:=10ed8eefd760e5819efcf3277b118f47
# space separated list or special @SF for sourceforge projects
PKG_SOURCE_URL:=ftp://ftp.openbsd.org/pub/OpenBSD/OpenNTPD/ \
@@ -25,6 +25,8 @@ $(PKG_BUILD_DIR)/.configured:
(cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
$(TARGET_CONFIGURE_OPTS) \
CFLAGS="$(TARGET_CFLAGS)" \
+ autoconf ; \
+ autoheader ; \
./configure \
--target=$(GNU_TARGET_NAME) \
--host=$(GNU_TARGET_NAME) \
@@ -47,6 +49,7 @@ $(PKG_BUILD_DIR)/.configured:
$(DISABLE_NLS) \
--with-builtin-arc4random \
--with-privsep-user=ntp \
+ --with-adjtimex \
);
touch $@