summaryrefslogtreecommitdiffstats
path: root/openwrt/package/nvram/src/Makefile
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-07-24 19:58:14 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-07-24 19:58:14 +0000
commitb401d50c8b3b367ea61af8fdf2ce44440a51a3a8 (patch)
tree2127b232ba8b642de1105e7cc7f0d1c60563c4bf /openwrt/package/nvram/src/Makefile
parent29313d8ecfcd32a92d5e3501baf3036c863ff91a (diff)
move wificonf and nvram stuff back to package/, remove build_mipsel/root, run install part of package/ for every board/kernel - fixes dependency mess
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1540 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/nvram/src/Makefile')
-rw-r--r--openwrt/package/nvram/src/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/openwrt/package/nvram/src/Makefile b/openwrt/package/nvram/src/Makefile
new file mode 100644
index 000000000..376c2b7de
--- /dev/null
+++ b/openwrt/package/nvram/src/Makefile
@@ -0,0 +1,22 @@
+# $Id$
+
+EXTRA_CFLAGS := -c -I. -I../include
+LIBSHARED_OBJS := shutils.o wl.o wl_linux.o defaults.o linux_timer.o
+LIBNVRAM_OBJS := nvram_linux.o nvram_convert.o
+
+all: libshared.so libnvram.so nvram
+
+%.o: %.c
+ $(CC) $(CFLAGS) $(EXTRA_CFLAGS) -o $@ $^
+
+libshared.so: $(LIBSHARED_OBJS)
+ $(CC) -shared -o $@ $^
+
+libnvram.so: $(LIBNVRAM_OBJS)
+ $(CC) -shared -o $@ $^
+
+nvram: main.o
+ $(CC) -o $@ $^ -L. -lnvram
+
+clean:
+ rm -f *.o *.so nvram