summaryrefslogtreecommitdiffstats
path: root/openwrt/package/lua
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-10-22 12:12:59 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-10-22 12:12:59 +0000
commit1f96d69f566aa785c0f0fb4fb25e6198a96bb4c3 (patch)
tree3a8d2dbe1cbd55d44f3348a768356c53977a2d0e /openwrt/package/lua
parent163fe567de49fa993f2b35cb469a87868adffa72 (diff)
lots of small package changes and dependency cleanups for the V= stuff
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@2230 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/lua')
-rw-r--r--openwrt/package/lua/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/openwrt/package/lua/Makefile b/openwrt/package/lua/Makefile
index 95f5fec12..4b062de33 100644
--- a/openwrt/package/lua/Makefile
+++ b/openwrt/package/lua/Makefile
@@ -27,7 +27,7 @@ $(eval $(call PKG_template,LUA_EXAMPLES,lua-examples,$(PKG_VERSION)-$(PKG_RELEAS
$(PKG_BUILD_DIR)/.configured:
touch $@
-$(PKG_BUILD_DIR)/.built:
+$(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
$(MAKE) -C $(PKG_BUILD_DIR) \
CC="$(TARGET_CROSS)gcc" \
LD="$(TARGET_CROSS)ld" \
@@ -96,5 +96,5 @@ uninstall-dev:
$(STAGING_DIR)/usr/include/lauxlib.h \
$(STAGING_DIR)/usr/lib/liblua{,lib}.{a,so*} \
-compile: install-dev
-clean: uninstall-dev
+compile-targets: install-dev
+clean-targets: uninstall-dev