summaryrefslogtreecommitdiffstats
path: root/openwrt/package/linux/linux.mk
diff options
context:
space:
mode:
authorwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-02-19 13:00:30 +0000
committerwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-02-19 13:00:30 +0000
commit6331e0d599b67379c2bee1d584cf42ab94e9fc9e (patch)
tree5ff9396a098d631bae3a7d7c70bd4d9fa294a8af /openwrt/package/linux/linux.mk
parentc774a728f37181d400e26edfcc15e4d3e6510249 (diff)
demistifying make *clean targets, fix some clean targets issues
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@272 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/linux/linux.mk')
-rw-r--r--openwrt/package/linux/linux.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/openwrt/package/linux/linux.mk b/openwrt/package/linux/linux.mk
index 6d4545b3c..bead2226a 100644
--- a/openwrt/package/linux/linux.mk
+++ b/openwrt/package/linux/linux.mk
@@ -57,6 +57,12 @@ endif
$(LINUX_DIR)/.configured: $(LINUX_DIR)/.patched
-cp $(LINUX_KCONFIG) $(LINUX_DIR)/.config
+ifeq ($(BR2_TARGET_ROOTFS_SQUASHFS_LZMA),y)
+ $(SED) "s,rootfstype=jffs2,rootfstype=squashfs," $(LINUX_DIR)/.config
+endif
+ifeq ($(BR2_TARGET_ROOTFS_SQUASHFS),y)
+ $(SED) "s,rootfstype=jffs2,rootfstype=squashfs," $(LINUX_DIR)/.config
+endif
$(SED) "s,^CROSS_COMPILE.*,CROSS_COMPILE=$(KERNEL_CROSS),g;" $(LINUX_DIR)/Makefile
$(SED) "s,^CROSS_COMPILE.*,CROSS_COMPILE=$(KERNEL_CROSS),g;" $(LINUX_DIR)/arch/mips/Makefile
$(SED) "s,\-mcpu=,\-mtune=,g;" $(LINUX_DIR)/arch/mips/Makefile