summaryrefslogtreecommitdiffstats
path: root/openwrt/package/linux/kernel-patches/022-drivers_net_Makefile
diff options
context:
space:
mode:
authorwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-03-26 10:33:32 +0000
committerwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-03-26 10:33:32 +0000
commit94756d4adc16a70d53f4db8fec8248aae2256af9 (patch)
treeb1a6b2b8bf2ee89d8a00610f25347828df4846fb /openwrt/package/linux/kernel-patches/022-drivers_net_Makefile
parentf26476c862bc76370a3884555d8677c9886eb792 (diff)
uncompress patches, requested by Kaloz
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@460 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/linux/kernel-patches/022-drivers_net_Makefile')
-rw-r--r--openwrt/package/linux/kernel-patches/022-drivers_net_Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/openwrt/package/linux/kernel-patches/022-drivers_net_Makefile b/openwrt/package/linux/kernel-patches/022-drivers_net_Makefile
new file mode 100644
index 000000000..8340c9565
--- /dev/null
+++ b/openwrt/package/linux/kernel-patches/022-drivers_net_Makefile
@@ -0,0 +1,48 @@
+--- ../../../kernel/linux-mips-cvs/drivers/net/Makefile 2004-08-14 20:38:51.000000000 +0200
++++ linux/drivers/net/Makefile 2005-03-16 12:45:24.523263597 +0100
+@@ -21,6 +21,16 @@
+ list-multi := rcpci.o
+ rcpci-objs := rcpci45.o rclanmtl.o
+
++subdir-m += diag
++
++ifeq ($(CONFIG_HW_QOS),y)
++subdir-m += port_based_qos
++else
++ ifeq ($(CONFIG_PERFORMANCE),y)
++ subdir-m += port_based_qos
++ endif
++endif
++
+ ifeq ($(CONFIG_TULIP),y)
+ obj-y += tulip/tulip.o
+ endif
+@@ -265,6 +275,28 @@
+ endif
+ endif
+
++#
++# Broadcom HND devices
++#
++ifdef CONFIG_HND
++subdir-$(CONFIG_HND) += hnd
++endif
++ifdef CONFIG_ET
++subdir-$(CONFIG_ET) += et
++endif
++ifdef CONFIG_WL
++subdir-$(CONFIG_WL) += wl
++endif
++ifeq ($(CONFIG_HND),y)
++ obj-y += hnd/hnd.o
++endif
++ifeq ($(CONFIG_ET),y)
++ obj-y += et/et.o
++endif
++ifeq ($(CONFIG_WL),y)
++ obj-y += wl/wl.o
++endif
++
+ include $(TOPDIR)/Rules.make
+
+ clean: