summaryrefslogtreecommitdiffstats
path: root/openwrt/package/linux/Makefile
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-04-02 19:30:30 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-04-02 19:30:30 +0000
commitefcafbd73d6233ad17d2d906bef363ad10518f53 (patch)
tree4327ceac9567e871984f53680bd892643ecdff4f /openwrt/package/linux/Makefile
parent929a1e6d81b96a074fa317749377cc26bdd6a379 (diff)
package wl and et and make them removable
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@532 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/linux/Makefile')
-rw-r--r--openwrt/package/linux/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/openwrt/package/linux/Makefile b/openwrt/package/linux/Makefile
index 771a9979d..29a1bfa30 100644
--- a/openwrt/package/linux/Makefile
+++ b/openwrt/package/linux/Makefile
@@ -38,6 +38,12 @@ $$(PKG_$(1)): $(LINUX_DIR)/.modules_done
endef
+$(eval $(call KMOD_template,BRCM_WL,brcm-wl,\
+ $(MODULES_DIR)/kernel/drivers/net/wl/wl.o \
+,CONFIG_WL))
+$(eval $(call KMOD_template,BRCM_ET,brcm-et,\
+ $(MODULES_DIR)/kernel/drivers/net/et/et.o \
+,CONFIG_ET))
$(eval $(call KMOD_template,ARPT,arptables,\
$(MODULES_DIR)/kernel/net/ipv4/netfilter/arp*.o \
,CONFIG_IP_NF_ARPTABLES))