summaryrefslogtreecommitdiffstats
path: root/openwrt/package/libpng/patches/101-pkgconfig-install.patch
diff options
context:
space:
mode:
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-05-19 20:41:53 +0000
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-05-19 20:41:53 +0000
commit55608abf95fe33ee2b82ea2d14d36a4dab0f3fd4 (patch)
treefbaaa558488c1de96934387baa45c45d2b53fe40 /openwrt/package/libpng/patches/101-pkgconfig-install.patch
parentb421566bc337d9ca813b26d675a6d73bc6b80677 (diff)
Add a patch for libpng's pkgconfig install
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@962 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/libpng/patches/101-pkgconfig-install.patch')
-rw-r--r--openwrt/package/libpng/patches/101-pkgconfig-install.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/openwrt/package/libpng/patches/101-pkgconfig-install.patch b/openwrt/package/libpng/patches/101-pkgconfig-install.patch
new file mode 100644
index 000000000..7f362fbc3
--- /dev/null
+++ b/openwrt/package/libpng/patches/101-pkgconfig-install.patch
@@ -0,0 +1,21 @@
+--- libpng-1.2.8-config/Makefile.in.orig 2004-12-03 01:14:51.000000000 +0100
++++ libpng-1.2.8-config/Makefile.in 2005-05-18 14:17:31.000000000 +0200
+@@ -874,13 +874,13 @@
+ cp libpng.pc libpng12.pc
+
+ install-data-local: libpng.pc libpng12.pc
+- @INSTALL@ -d @PKGCONFIGDIR@
+- @INSTALL_DATA@ libpng.pc @PKGCONFIGDIR@
+- @INSTALL_DATA@ libpng12.pc @PKGCONFIGDIR@
++ @INSTALL@ -d $(DESTDIR)@PKGCONFIGDIR@
++ @INSTALL_DATA@ libpng.pc $(DESTDIR)@PKGCONFIGDIR@
++ @INSTALL_DATA@ libpng12.pc $(DESTDIR)@PKGCONFIGDIR@
+
+ uninstall-local:
+- rm -f @PKGCONFIGDIR@/libpng.pc
+- rm -f @PKGCONFIGDIR@/libpng12.pc
++ rm -f $(DESTDIR)@PKGCONFIGDIR@/libpng.pc
++ rm -f $(DESTDIR)@PKGCONFIGDIR@/libpng12.pc
+
+ libpng-config:
+ ( cat ${srcdir}/scripts/libpng-config-head.in; \