summaryrefslogtreecommitdiffstats
path: root/openwrt/package/iptables/kernelconfig.mk
diff options
context:
space:
mode:
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-03-06 14:12:21 +0000
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-03-06 14:12:21 +0000
commitdb540460f8324f349a2bc044ee0350a8be99cb4f (patch)
tree1abb2e1f25a6b3baa3f8c794ae64bfe4307aaaeb /openwrt/package/iptables/kernelconfig.mk
parent588c210a4700e2a91be943a33707487a190d9d70 (diff)
Add missing iptables extensions
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@318 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/iptables/kernelconfig.mk')
-rw-r--r--openwrt/package/iptables/kernelconfig.mk6
1 files changed, 4 insertions, 2 deletions
diff --git a/openwrt/package/iptables/kernelconfig.mk b/openwrt/package/iptables/kernelconfig.mk
index b04ba54c2..18c8e7540 100644
--- a/openwrt/package/iptables/kernelconfig.mk
+++ b/openwrt/package/iptables/kernelconfig.mk
@@ -23,6 +23,7 @@ ext-$(CONFIG_IP_NF_MATCH_OWNER) += owner
ext-$(CONFIG_IP_NF_MATCH_PHYSDEV) += physdev
ext-$(CONFIG_IP_NF_TARGET_MASQUERADE) += MASQUERADE
ext-$(CONFIG_IP_NF_TARGET_REDIRECT) += REDIRECT
+ext-$(CONFIG_IP_NF_TARGET_REJECT) += REJECT
ext-$(CONFIG_IP_NF_TARGET_TOS) += TOS
ext-$(CONFIG_IP_NF_TARGET_ECN) += ECN
ext-$(CONFIG_IP_NF_TARGET_DSCP) += DSCP
@@ -31,5 +32,6 @@ ext-$(CONFIG_IP_NF_TARGET_LOG) += LOG
ext-$(CONFIG_IP_NF_TARGET_ULOG) += ULOG
ext-$(CONFIG_IP_NF_TARGET_TCPMSS) += TCPMSS
-
-
+# add extensions that don't depend on kernel config
+ext-m += TTL
+ext-y += icmp standard tcp udp