summaryrefslogtreecommitdiffstats
path: root/openwrt/package/iptables/Makefile
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-04-05 02:09:22 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-04-05 02:09:22 +0000
commit93701b2bec2b99d8113d8a6d9b97153e87a7e5aa (patch)
tree2a8ba6aa03cd4a2eaaa417fd47c30ebc71e73e5f /openwrt/package/iptables/Makefile
parent9ce1fe9aaa459cf48fcb1e89537cbe0456d7dfac (diff)
large init script cleanup and merge of whiterussian changes, new dnsmasq config handling
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@3588 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/iptables/Makefile')
-rw-r--r--openwrt/package/iptables/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/openwrt/package/iptables/Makefile b/openwrt/package/iptables/Makefile
index 298a9a9e0..f16ac8be4 100644
--- a/openwrt/package/iptables/Makefile
+++ b/openwrt/package/iptables/Makefile
@@ -72,6 +72,13 @@ $(PKG_BUILD_DIR)/.built:
touch $@
$(IPKG_IPTABLES):
+ install -d -m0755 $(IDIR_IPTABLES)/etc/config
+ install -m0644 ./files/firewall.config $(IDIR_IPTABLES)/etc/config/firewall
+ install -d -m0755 $(IDIR_IPTABLES)/etc/init.d
+ install -m0755 ./files/firewall.init $(IDIR_IPTABLES)/etc/init.d/S45firewall
+ install -m0755 ./files/firewall.user $(IDIR_IPTABLES)/etc/
+ install -d -m0755 $(IDIR_IPTABLES)/usr/lib
+ install -m0644 ./files/firewall.awk $(IDIR_IPTABLES)/usr/lib
install -d -m0755 $(IDIR_IPTABLES)/usr/sbin
$(CP) $(PKG_INSTALL_DIR)/usr/sbin/iptables $(IDIR_IPTABLES)/usr/sbin/
install -d -m0755 $(IDIR_IPTABLES)/usr/lib/iptables