summaryrefslogtreecommitdiffstats
path: root/openwrt/package/httping/patches
diff options
context:
space:
mode:
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-02-13 12:58:34 +0000
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-02-13 12:58:34 +0000
commit8ce48bdf4514ceafa03232fc722a10a5cae9a088 (patch)
tree2f99fd8c159b504f6ccfe59cb1404f3a8d4fab9c /openwrt/package/httping/patches
parent556cad808f902654620ae6007951816395660fd0 (diff)
Added support for SSL
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@3232 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/httping/patches')
-rw-r--r--openwrt/package/httping/patches/01-honor_includes_lib-paths.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/openwrt/package/httping/patches/01-honor_includes_lib-paths.patch b/openwrt/package/httping/patches/01-honor_includes_lib-paths.patch
new file mode 100644
index 000000000..92817c7b3
--- /dev/null
+++ b/openwrt/package/httping/patches/01-honor_includes_lib-paths.patch
@@ -0,0 +1,26 @@
+diff -urN httping-1.0.10.orig/io.c httping-1.0.10/io.c
+--- httping-1.0.10.orig/io.c 2006-02-13 13:48:37.645232976 +0100
++++ httping-1.0.10/io.c 2006-02-13 13:48:24.083294704 +0100
+@@ -37,7 +37,7 @@
+ struct timeval to;
+ fd_set rfds;
+
+- FD_ZERO(&rfds);
++ //FD_ZERO(&rfds);
+ FD_SET(fd, &rfds);
+
+ to.tv_sec = timeout / 1000;
+diff -urN httping-1.0.10.orig/Makefile httping-1.0.10/Makefile
+--- httping-1.0.10.orig/Makefile 2006-01-02 17:07:29.000000000 +0100
++++ httping-1.0.10/Makefile 2006-02-13 13:44:45.066590304 +0100
+@@ -15,8 +15,8 @@
+ VERSION=1.0.10
+
+ DEBUG=-g
+-LDFLAGS+=-lssl -lcrypto $(DEBUG)
+-CFLAGS+=-O2 -Wall -DVERSION=\"$(VERSION)\" $(DEBUG)
++LDFLAGS+=-lssl -lcrypto $(DEBUG) -L$(STAGING_DIR)/usr/lib
++CFLAGS+=-O2 -Wall -DVERSION=\"$(VERSION)\" $(DEBUG) -I$(STAGING_DIR)/usr/include
+
+ OBJS=http.o io.o str.o error.o utils.o main.o tcp.o mssl.o res.o
+