summaryrefslogtreecommitdiffstats
path: root/openwrt/package/expat/Makefile
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-10-22 01:40:50 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-10-22 01:40:50 +0000
commit25768f1c4d22195764ef1e818d25d2b14f95bb97 (patch)
tree2a9e4e72bd37b0af8c11076de92ac3edcb2ec3ce /openwrt/package/expat/Makefile
parentc65955aa6a15b044fcdb98b09544536a57a6692c (diff)
add some more verbosity stuff
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@2222 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/expat/Makefile')
-rw-r--r--openwrt/package/expat/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/openwrt/package/expat/Makefile b/openwrt/package/expat/Makefile
index 6ad7d8552..ef9f3a9b5 100644
--- a/openwrt/package/expat/Makefile
+++ b/openwrt/package/expat/Makefile
@@ -18,7 +18,7 @@ include $(TOPDIR)/package/rules.mk
$(eval $(call PKG_template,LIBEXPAT,libexpat,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
+$(PKG_BUILD_DIR)/.configured:
(cd $(PKG_BUILD_DIR) ; rm -rf config.{cache,status} ; \
$(TARGET_CONFIGURE_OPTS) \
CFLAGS="$(TARGET_CFLAGS)" \
@@ -49,7 +49,7 @@ $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
);
touch $@
-$(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
+$(PKG_BUILD_DIR)/.built:
rm -rf $(PKG_INSTALL_DIR)
mkdir -p $(PKG_INSTALL_DIR)
$(MAKE) -C $(PKG_BUILD_DIR) \
@@ -80,8 +80,8 @@ uninstall-dev:
$(STAGING_DIR)/usr/include/expat*.h \
$(STAGING_DIR)/usr/lib/libexpat.{a,so*} \
-compile: install-dev
-clean: uninstall-dev
+compile-targets: install-dev
+clean-targets: uninstall-dev
mostlyclean:
make -C $(PKG_BUILD_DIR) clean