summaryrefslogtreecommitdiffstats
path: root/openwrt/package/dropbear/Makefile
diff options
context:
space:
mode:
authorwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-03-21 08:12:49 +0000
committerwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-03-21 08:12:49 +0000
commitec8fa5540e88f076526bfaa388c8a4d406e37bff (patch)
tree9746d68e62ad8ee899d82224609b6e7924364e40 /openwrt/package/dropbear/Makefile
parent0d8d0c34edda6c930a1dcda0f057ac514ef90f80 (diff)
add md5sums
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@405 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/dropbear/Makefile')
-rw-r--r--openwrt/package/dropbear/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/openwrt/package/dropbear/Makefile b/openwrt/package/dropbear/Makefile
index a62e25131..48d0068c4 100644
--- a/openwrt/package/dropbear/Makefile
+++ b/openwrt/package/dropbear/Makefile
@@ -1,11 +1,10 @@
-#############################################################
-#
-# dropbear
-#
-#############################################################
+# $Id$
+
include $(TOPDIR)/rules.mk
DROPBEAR_VERSION:=0.45
+DROPBEAR_MD5SUM:=2bcc46e4c239aec982bf36a723dd0b0e
+
DROPBEAR_SOURCE:=dropbear-$(DROPBEAR_VERSION).tar.bz2
DROPBEAR_SITE:=http://matt.ucc.asn.au/dropbear/releases/
DROPBEAR_DIR:=$(BUILD_DIR)/dropbear-$(DROPBEAR_VERSION)
@@ -16,7 +15,7 @@ DROPBEAR_IPK:=dropbear_$(DROPBEAR_VERSION)-1_$(ARCH).ipk
DROPBEAR_IPK_DIR:=$(DROPBEAR_DIR)/ipkg
$(DL_DIR)/$(DROPBEAR_SOURCE):
- $(SCRIPT_DIR)/download.pl $(DL_DIR) $(DROPBEAR_SOURCE) x $(DROPBEAR_SITE)
+ $(SCRIPT_DIR)/download.pl $(DL_DIR) $(DROPBEAR_SOURCE) $(DROPBEAR_MD5SUM) $(DROPBEAR_SITE)
$(DROPBEAR_DIR)/.patched: $(DL_DIR)/$(DROPBEAR_SOURCE)
$(DROPBEAR_CAT) $(DL_DIR)/$(DROPBEAR_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -