summaryrefslogtreecommitdiffstats
path: root/openwrt/package/asterisk/patches
diff options
context:
space:
mode:
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-05-07 19:05:51 +0000
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-05-07 19:05:51 +0000
commit6de0c2173e8c5d584c8b428b5ab05bbc124b0b42 (patch)
tree4831945f46f46345637129b422a2563ce63ed7bb /openwrt/package/asterisk/patches
parent00f015c40d74d0b8005e07b71d1e174c1cca5127 (diff)
make asterisk chan_bluetooth and chan_h323 modules optional,
link openh323 and pwlib statically. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@3737 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/asterisk/patches')
-rw-r--r--openwrt/package/asterisk/patches/asterisk-1.0.9-chan_bluetooth.patch15
-rw-r--r--openwrt/package/asterisk/patches/asterisk-1.2.1-chan_h323.patch32
2 files changed, 35 insertions, 12 deletions
diff --git a/openwrt/package/asterisk/patches/asterisk-1.0.9-chan_bluetooth.patch b/openwrt/package/asterisk/patches/asterisk-1.0.9-chan_bluetooth.patch
index 7c278a71b..4f3425db3 100644
--- a/openwrt/package/asterisk/patches/asterisk-1.0.9-chan_bluetooth.patch
+++ b/openwrt/package/asterisk/patches/asterisk-1.0.9-chan_bluetooth.patch
@@ -1,23 +1,14 @@
diff -ruN asterisk-1.0.9-old/channels/Makefile asterisk-1.0.9-new/channels/Makefile
--- asterisk-1.0.9-old/channels/Makefile 2005-08-22 20:42:22.000000000 +0200
+++ asterisk-1.0.9-new/channels/Makefile 2005-08-22 21:12:14.000000000 +0200
-@@ -37,6 +37,12 @@
- #
- #CHANNEL_LIBS+=chan_vofr
+@@ -202,6 +202,13 @@
+ chan_h323.so: chan_h323.o h323/libchanh323.a
+ $(CC) $(SOLINK) -o $@ $< h323/libchanh323.a $(CHANH323LIB) -L$(PWLIBDIR)/lib $(PTLIB) -L$(OPENH323DIR)/lib $(H323LIB) -L/usr/lib -lcrypto -lssl -lexpat
+#
+# Asterisk Bluetooth Support
+# http://www.crazygreek.co.uk/content/chan_bluetooth
+#
-+CHANNEL_LIBS += chan_bluetooth.so
-+
- ifeq (${OSARCH},OpenBSD)
- MYSQLLIB=-L/usr/local/lib/mysql -lmysqlclient
- CFLAGS+=-I/usr/local/include
-@@ -202,6 +208,9 @@
- chan_h323.so: chan_h323.o h323/libchanh323.a
- $(CC) $(SOLINK) -o $@ $< h323/libchanh323.a $(CHANH323LIB) -L$(PWLIBDIR)/lib $(PTLIB) -L$(OPENH323DIR)/lib $(H323LIB) -L/usr/lib -lcrypto -lssl -lexpat
-
+chan_bluetooth.so: chan_bluetooth.o
+ $(CC) $(SOLINK) -o $@ $< $(EXTRA_LDFLAGS) -lbluetooth
+
diff --git a/openwrt/package/asterisk/patches/asterisk-1.2.1-chan_h323.patch b/openwrt/package/asterisk/patches/asterisk-1.2.1-chan_h323.patch
new file mode 100644
index 000000000..10760de0b
--- /dev/null
+++ b/openwrt/package/asterisk/patches/asterisk-1.2.1-chan_h323.patch
@@ -0,0 +1,32 @@
+diff -ruN asterisk-1.2.1-old/channels/Makefile asterisk-1.2.1-new/channels/Makefile
+--- asterisk-1.2.1-old/channels/Makefile 2006-05-07 13:06:06.000000000 +0200
++++ asterisk-1.2.1-new/channels/Makefile 2006-05-07 15:26:00.000000000 +0200
+@@ -15,6 +15,7 @@
+ #
+
+ CHANNEL_LIBS=chan_sip.so chan_agent.so chan_mgcp.so chan_iax2.so chan_local.so chan_skinny.so chan_features.so
++CXXLIBS=-lstdc++
+
+ ifneq (${OSARCH},CYGWIN)
+ # if you really, really want to use these drivers, uncomment the line below
+@@ -230,7 +231,7 @@
+
+ ifeq (${OSARCH},Linux)
+ chan_h323.so: chan_h323.o h323/libchanh323.a h323/Makefile.ast
+- $(CC) $(SOLINK) $(H323LDFLAGS) -o $@ $< h323/libchanh323.a $(H323LDLIBS) -lstdc++
++ $(CC) $(SOLINK) $(H323LDFLAGS) -o $@ $< h323/libchanh323.a $(H323LDLIBS) $(CXXLIBS)
+ else
+ chan_h323.so: chan_h323.o h323/libchanh323.a
+ $(CC) $(SOLINK) -o $@ $< h323/libchanh323.a $(CHANH323LIB) -L$(PWLIBDIR)/lib $(PTLIB) -L$(OPENH323DIR)/lib $(H323LIB) -L/usr/lib -lcrypto -lssl -lexpat
+diff -ruN asterisk-1.2.1-old/channels/h323/Makefile asterisk-1.2.1-new/channels/h323/Makefile
+--- asterisk-1.2.1-old/channels/h323/Makefile 2005-11-29 19:24:39.000000000 +0100
++++ asterisk-1.2.1-new/channels/h323/Makefile 2006-05-07 13:18:46.000000000 +0200
+@@ -30,7 +30,7 @@
+ touch $(SOURCES)
+
+ libchanh323.a: $(OBJS)
+- ar crv $@ $(OBJS)
++ $(AR) crv $@ $(OBJS)
+
+ Makefile.ast: FORCE
+ @echo H323CFLAGS = $(STDCCFLAGS) $(OPTCCFLAGS) $(CFLAGS) >$@.tmp