summaryrefslogtreecommitdiffstats
path: root/openwrt/package/asterisk/patches/asterisk-1.0.7-Makefile-channels-h323.patch
diff options
context:
space:
mode:
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-07-11 12:48:09 +0000
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-07-11 12:48:09 +0000
commit804c78b471c1e447cf4431f7afdfd6e0b20b75d0 (patch)
tree7196b03459252abed6f51691e6558b6f61d6d96f /openwrt/package/asterisk/patches/asterisk-1.0.7-Makefile-channels-h323.patch
parentcdea47b22effe86885cb0517fe5bdf02d95d1a76 (diff)
Update to new upstream release (v1.0.9),
Split makefile patch into multiple patches, Add no-gtk fix from whiterussian. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1402 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/asterisk/patches/asterisk-1.0.7-Makefile-channels-h323.patch')
-rw-r--r--openwrt/package/asterisk/patches/asterisk-1.0.7-Makefile-channels-h323.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/openwrt/package/asterisk/patches/asterisk-1.0.7-Makefile-channels-h323.patch b/openwrt/package/asterisk/patches/asterisk-1.0.7-Makefile-channels-h323.patch
new file mode 100644
index 000000000..8d8932875
--- /dev/null
+++ b/openwrt/package/asterisk/patches/asterisk-1.0.7-Makefile-channels-h323.patch
@@ -0,0 +1,33 @@
+diff -ruN asterisk-1.0.7-old/channels/h323/Makefile asterisk-1.0.7-new/channels/h323/Makefile
+--- asterisk-1.0.7-old/channels/h323/Makefile 2004-11-15 03:35:35.000000000 +0100
++++ asterisk-1.0.7-new/channels/h323/Makefile 2005-03-19 17:38:06.000000000 +0100
+@@ -22,9 +22,11 @@
+ OSARCH=$(shell uname -s)
+ ifneq (${OSARCH},FreeBSD)
+ ifneq (${OSARCH},NetBSD)
++ifneq ($(PROC),mipsel)
+ CFLAGS += -march=$(shell uname -m)
+ endif
+ endif
++endif
+ CFLAGS += -DPBYTE_ORDER=PLITTLE_ENDIAN
+
+ ifeq (${OSARCH},Linux)
+@@ -47,7 +49,7 @@
+
+ # Pre Janus release directives
+ CFLAGS += -DNDEBUG -DDO_CRASH -DDEBUG_THREADS
+-CFLAGS += -pipe -Wall -fPIC
++CFLAGS += -pipe -Wall -fPIC $(OPTIMIZE)
+ ifeq (${OSARCH},Linux)
+ CFLAGS += -DP_LINUX
+ LIBS+=-lpthread
+@@ -74,7 +76,7 @@
+
+
+ libchanh323.a: ast_h323.o
+- ar cr libchanh323.a ast_h323.o
++ $(AR) cr libchanh323.a ast_h323.o
+
+ ast_h323.o: ast_h323.cpp
+ $(CXX) -g -c -fno-rtti -o $@ $(CFLAGS) $<