summaryrefslogtreecommitdiffstats
path: root/openwrt/package/Makefile
diff options
context:
space:
mode:
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-04-18 06:41:36 +0000
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-04-18 06:41:36 +0000
commit7eaccfbb4e6544d4af3e389c1020e76d95f89fe6 (patch)
tree7447f09ef9421fb72eadde3de35efc00f30e37d1 /openwrt/package/Makefile
parentb10d5eeac9f5b4d71e7568e38a0f1ee4be704841 (diff)
Add snort package, with experimental -custom package for build-time package customizations
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@667 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/Makefile')
-rw-r--r--openwrt/package/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/openwrt/package/Makefile b/openwrt/package/Makefile
index 9259e4c33..bd938800d 100644
--- a/openwrt/package/Makefile
+++ b/openwrt/package/Makefile
@@ -51,6 +51,7 @@ package-$(BR2_PACKAGE_SDK) += sdk
package-$(BR2_PACKAGE_SER) += ser
package-$(BR2_PACKAGE_SETSERIAL) += setserial
package-$(BR2_PACKAGE_SHFS) += shfs
+package-$(BR2_PACKAGE_SNORT) += snort
package-$(BR2_PACKAGE_SPEEX) += speex
package-$(BR2_PACKAGE_STRACE) += strace
package-$(BR2_PACKAGE_TCPDUMP) += tcpdump
@@ -97,6 +98,14 @@ libnet-compile: libpcap-compile
mysql-compile: ncurses-compile zlib-compile
postgresql-compile: zlib-compile
+snort-compile: libnet-compile libpcap-compile pcre-compile
+ifeq ($(BR2_PACKAGE_SNORT_MYSQL),y)
+snort-compile: mysql-compile
+endif
+ifeq ($(BR2_PACKAGE_SNORT_PGSQL),y)
+snort-compile: postgresql-compile
+endif
+
sdk-compile: $(DEV_LIBS_COMPILE)
$(patsubst %,%-prepare,$(package-y) $(package-m) $(package-)): linux-install