summaryrefslogtreecommitdiffstats
path: root/openwrt/package/Makefile
diff options
context:
space:
mode:
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-11-06 16:06:51 +0000
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-11-06 16:06:51 +0000
commit1a7c5d7335884e86eac17257266bfb582983cf83 (patch)
treed8a1ec1170db9fe6628736fdca51bb881a98016d /openwrt/package/Makefile
parent7e66ceed5875cde01380aabc158305baa84dddf9 (diff)
add snort-wireless package (thanks to Florian Fainelli)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@2354 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/Makefile')
-rw-r--r--openwrt/package/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/openwrt/package/Makefile b/openwrt/package/Makefile
index bf4e425b5..9b5fe61e9 100644
--- a/openwrt/package/Makefile
+++ b/openwrt/package/Makefile
@@ -176,6 +176,7 @@ package-$(BR2_COMPILE_SHFS) += shfs
package-$(BR2_PACKAGE_SIPROXD) += siproxd
package-$(BR2_PACKAGE_SIPSAK) += sipsak
package-$(BR2_COMPILE_SNORT) += snort
+package-$(BR2_COMPILE_SNORT_WIRELESS) += snort-wireless
package-$(BR2_PACKAGE_SOCAT) += socat
package-$(BR2_COMPILE_SPEEX) += speex
package-$(BR2_COMPILE_SQLITE) += sqlite
@@ -426,6 +427,17 @@ ifeq ($(BR2_PACKAGE_SNORT_ENABLE_INLINE),y)
snort-compile: iptables-compile
endif
+snort-wireless-compile: libnet-compile libpcap-compile pcre-compile
+ifeq ($(BR2_PACKAGE_SNORT_WIRELESS_WITH_MYSQL),y)
+snort-wireless-compile: mysql-compile
+endif
+ifeq ($(BR2_PACKAGE_SNORT_WIRELESS_WITH_PGSQL),y)
+snort-wireless-compile: postgresql-compile
+endif
+ifeq ($(BR2_PACKAGE_SNORT_WIRELESS_ENABLE_INLINE),y)
+snort-wireless-compile: iptables-compile
+endif
+
ulogd-compile: iptables-compile
ifneq ($(BR2_PACKAGE_ULOGD_MOD_MYSQL),)
ulogd-compile: mysql-compile