summaryrefslogtreecommitdiffstats
path: root/openwrt/Makefile
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-03-21 16:15:01 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-03-21 16:15:01 +0000
commit51b7d1c140d009556c001c995ccc9c193fb3b77f (patch)
tree8167a4ffe77c882abd4cc35a76a7bf5463e92b30 /openwrt/Makefile
parenta3c0f30a1a298821bc58743924d3d1eaab7858bf (diff)
check config changes on make world
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@410 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/Makefile')
-rw-r--r--openwrt/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/openwrt/Makefile b/openwrt/Makefile
index 8342bab86..ef60ff198 100644
--- a/openwrt/Makefile
+++ b/openwrt/Makefile
@@ -69,9 +69,13 @@ package_install: toolchain
# In this section, we need .config
include .config.cmd
-world: $(DL_DIR) $(BUILD_DIR) target_prepare $(TARGET_DIR) toolchain_install package_install target_install package_index
+world: $(DL_DIR) $(BUILD_DIR) configtest target_prepare $(TARGET_DIR) toolchain_install package_install target_install package_index
-.PHONY: all world clean dirclean distclean image_clean target_clean source target_prepare target_install toolchain_install package_install
+.PHONY: all world clean dirclean distclean image_clean target_clean source target_prepare target_install toolchain_install package_install configtest
+
+configtest:
+ -cp .config .config.test
+ -scripts/configtest.pl
package_index:
(cd $(PACKAGE_DIR); \