summaryrefslogtreecommitdiffstats
path: root/obsolete-buildroot/sources
diff options
context:
space:
mode:
authorsolar <solar@3c298f89-4303-0410-b956-a3cf2f4a3e73>2004-06-04 02:00:59 +0000
committersolar <solar@3c298f89-4303-0410-b956-a3cf2f4a3e73>2004-06-04 02:00:59 +0000
commit326f4b5320ff49fe29f30e2e6e481580bd2c0d0b (patch)
tree1bc9fa785cde2101b565ecdf10dd03a41669237c /obsolete-buildroot/sources
parent189f306f493d95edd81164f60a3e67e0036b7740 (diff)
patch to allow iproute2 to be cross compiled. could be a sed hack if we wanted/needed.
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@57 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'obsolete-buildroot/sources')
-rw-r--r--obsolete-buildroot/sources/iproute2-cross-ar-20010824.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/obsolete-buildroot/sources/iproute2-cross-ar-20010824.patch b/obsolete-buildroot/sources/iproute2-cross-ar-20010824.patch
new file mode 100644
index 000000000..62ed488f9
--- /dev/null
+++ b/obsolete-buildroot/sources/iproute2-cross-ar-20010824.patch
@@ -0,0 +1,28 @@
+diff -Nrup iproute2.orig/lib/Makefile iproute2/lib/Makefile
+--- iproute2.orig/lib/Makefile 2000-04-16 13:42:52.000000000 -0400
++++ iproute2/lib/Makefile 2004-06-03 19:17:51.000000000 -0400
+@@ -6,10 +6,10 @@ NLOBJ=ll_map.o libnetlink.o
+ all: libnetlink.a libutil.a
+
+ libnetlink.a: $(NLOBJ)
+- ar rcs $@ $(NLOBJ)
++ $(AR) rcs $@ $(NLOBJ)
+
+ libutil.a: $(UTILOBJ) $(ADDLIB)
+- ar rcs $@ $(UTILOBJ) $(ADDLIB)
++ $(AR) rcs $@ $(UTILOBJ) $(ADDLIB)
+
+ clean:
+ rm -f $(NLOBJ) $(UTILOBJ) $(ADDLIB) libnetlink.a libutil.a
+diff -Nrup iproute2.orig/tc/Makefile iproute2/tc/Makefile
+--- iproute2.orig/tc/Makefile 2000-04-16 13:42:53.000000000 -0400
++++ iproute2/tc/Makefile 2004-06-03 19:18:08.000000000 -0400
+@@ -43,7 +43,7 @@ all: libtc.a tc
+ tc: $(TCOBJ) $(LIBNETLINK) $(LIBUTIL) $(TCLIB)
+
+ libtc.a: $(TCLIB)
+- ar rcs $@ $(TCLIB)
++ $(AR) rcs $@ $(TCLIB)
+
+ clean:
+ rm -f $(TCOBJ) $(TCLIB) libtc.a tc