summaryrefslogtreecommitdiffstats
path: root/obsolete-buildroot/Makefile
diff options
context:
space:
mode:
authormbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>2004-08-17 23:00:52 +0000
committermbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>2004-08-17 23:00:52 +0000
commitb46fe1c707bc971ac7c06b7545b21c666349f7f9 (patch)
tree84ebc770984bae282956c67d6b0b2234b2a56a70 /obsolete-buildroot/Makefile
parente2784f3bce41605cdae551531a6621ae9c1c043d (diff)
sstrip, nas support, mppe support, mac os x patches, syslogd on bootup, inittab correction
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@136 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'obsolete-buildroot/Makefile')
-rw-r--r--obsolete-buildroot/Makefile23
1 files changed, 7 insertions, 16 deletions
diff --git a/obsolete-buildroot/Makefile b/obsolete-buildroot/Makefile
index 7b60dd519..e534b44c4 100644
--- a/obsolete-buildroot/Makefile
+++ b/obsolete-buildroot/Makefile
@@ -40,9 +40,6 @@ BUILD_WITH_LARGEFILE:=true
OPTIMIZE_FOR_CPU=$(ARCH)
-# directory used by 'make publish'
-PUB_DIR:=/var/www/html/testsite/ipkg
-
# Command used to download source code
WGET:=wget --passive-ftp
@@ -151,7 +148,6 @@ TARGET_CROSS=$(STAGING_DIR)/bin/$(OPTIMIZE_FOR_CPU)-linux-uclibc-
TARGET_CC=$(TARGET_CROSS)gcc
STRIP=$(TARGET_CROSS)strip --remove-section=.comment --remove-section=.note
-
HOST_ARCH:=$(shell $(HOSTCC) -dumpmachine | sed -e s'/-.*//' \
-e 's/sparc.*/sparc/' \
-e 's/arm.*/arm/g' \
@@ -191,13 +187,14 @@ TARGETS_DIRCLEAN:=$(patsubst %,%-dirclean,$(TARGETS))
PACKAGES_IPK:=$(patsubst %,%-ipk,$(PACKAGES))
OPENWRT_IPK_DIR=$(SOURCE_DIR)/openwrt/ipkg
-$(BUILD_DIR)/Packages : $(PACKAGES_IPK)
- (cd $(BUILD_DIR) ; $(IPKG_MAKE_INDEX) . > Packages)
-
world: $(DL_DIR) $(TARGETS_SOURCE) $(BUILD_DIR) $(STAGING_DIR) $(TARGET_DIR) $(TARGETS)
@echo "ALL DONE."
-packages: ipkg-utils $(PACKAGES_IPK) $(BUILD_DIR)/Packages
+packages: ipkg-utils $(PACKAGES_IPK)
+ -@mkdir -p $(BASE_DIR)/packages
+ cd $(BASE_DIR)/packages
+ -mv $(BUILD_DIR)/*.ipk .
+ $(IPKG_MAKE_INDEX) . > Packages
@echo "ALL DONE."
.PHONY: all world clean dirclean distclean source $(TARGETS) \
@@ -240,11 +237,13 @@ source: $(TARGETS_SOURCE)
#############################################################
clean:
rm -rf $(TOOL_BUILD_DIR) $(BUILD_DIR) $(IMAGE) \
+ $(BASE_DIR)/packages \
openwrt-linux.trx openwrt-g-code.bin openwrt-gs-code.bin \
openwrt-kmodules.tar.bz2
dirclean: $(TARGETS_DIRCLEAN)
rm -rf $(TARGET_DIR) $(STAGING_DIR) $(IMAGE) \
+ $(BASE_DIR)/packages \
openwrt-linux.trx openwrt-g-code.bin openwrt-gs-code.bin \
openwrt-kmodules.tar.bz2
@@ -253,14 +252,6 @@ distclean:
openwrt-linux.trx openwrt-g-code.bin openwrt-gs-code.bin \
openwrt-kmodules.tar.bz2
-publish:
- chmod 644 $(BUILD_DIR)/Packages
- chmod 644 $(BUILD_DIR)/Packages.filelist
- chmod 644 $(BUILD_DIR)/*.ipk
- cp $(BUILD_DIR)/Packages $(PUB_DIR)
- cp $(BUILD_DIR)/Packages.filelist $(PUB_DIR)
- cp $(BUILD_DIR)/*.ipk $(PUB_DIR)
-
sourceball:
rm -rf $(BUILD_DIR)
set -e; \