From 881ef53d90479df53c308a2470cdb48d8da267f6 Mon Sep 17 00:00:00 2001
From: nico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Thu, 19 May 2005 05:28:28 +0000
Subject: Tweaked aiccu package, add cvs Id to Makefile, fix aiccu init-script
 again (need some sleep, I guess)

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@947 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 openwrt/package/aiccu/Config.in        | 10 ++++++----
 openwrt/package/aiccu/Makefile         | 15 +++++++++++----
 openwrt/package/aiccu/files/aiccu      | 21 ---------------------
 openwrt/package/aiccu/files/aiccu.init | 21 +++++++++++++++++++++
 4 files changed, 38 insertions(+), 29 deletions(-)
 delete mode 100644 openwrt/package/aiccu/files/aiccu
 create mode 100644 openwrt/package/aiccu/files/aiccu.init

(limited to 'openwrt')

diff --git a/openwrt/package/aiccu/Config.in b/openwrt/package/aiccu/Config.in
index 5eb1c918a..cc2bfe21d 100644
--- a/openwrt/package/aiccu/Config.in
+++ b/openwrt/package/aiccu/Config.in
@@ -1,9 +1,11 @@
 config BR2_PACKAGE_AICCU
+	tristate "aiccu - SixXS Automatic IPv6 Connectivity Client Utility"
+	default m if CONFIG_DEVEL
 	select BR2_PACKAGE_KMOD_IPV6
 	select BR2_PACKAGE_LIBPTHREAD
-	tristate "aiccu"
-	default m if CONFIG_DEVEL
 	help
-	 SixXS Automatic IPv6 Connectivity Client Utility
+	  SixXS Automatic IPv6 Connectivity Client Utility
+	  
+	  For more information about SixXS check http://www.sixxs.net/
+	  
 
-	 For more information about SixXS check http://www.sixxs.net
diff --git a/openwrt/package/aiccu/Makefile b/openwrt/package/aiccu/Makefile
index 7d3633c49..5019b6562 100644
--- a/openwrt/package/aiccu/Makefile
+++ b/openwrt/package/aiccu/Makefile
@@ -1,3 +1,5 @@
+# $Id$
+
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=aiccu
@@ -7,22 +9,27 @@ PKG_MD5SUM:=7c3da5feab3d59fb5a99a45203e0ca56
 
 PKG_SOURCE_URL:=http://www.sixxs.net/archive/sixxs/aiccu/unix
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
 PKG_CAT:=zcat
 
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
+
 include $(TOPDIR)/package/rules.mk
 
 $(eval $(call PKG_template,AICCU,aiccu,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 
-$(PKG_BUILD_DIR)/.built:
+$(PKG_BUILD_DIR)/.configured:
 	$(SED) "s,strip,$(STRIP)," $(PKG_BUILD_DIR)/unix-console/Makefile
-	$(MAKE) CC=$(TARGET_CC) CFLAGS="$(TARGET_CFLAGS) -D_GNU_SOURCE" DEBUG=0 -C $(PKG_BUILD_DIR)
+	touch $@
+
+$(PKG_BUILD_DIR)/.built:
+	$(MAKE) -C $(PKG_BUILD_DIR) \
+		CC=$(TARGET_CC) CFLAGS="$(TARGET_CFLAGS) -D_GNU_SOURCE" DEBUG=0
 	touch $@
 
 $(IPKG_AICCU):
 	mkdir -p $(IDIR_AICCU)/usr/sbin $(IDIR_AICCU)/etc/init.d
 	install -m 755 $(PKG_BUILD_DIR)/unix-console/$(PKG_NAME) $(IDIR_AICCU)/usr/sbin/
-	install -m 755 ./files/S51aiccu $(IDIR_AICCU)/etc/init.d/
+	install -m 755 ./files/aiccu.init $(IDIR_AICCU)/etc/init.d/S51aiccu
 	install -m 644 $(PKG_BUILD_DIR)/doc/aiccu.conf $(IDIR_AICCU)/etc/aiccu.conf
 	$(STRIP) $(IDIR_AICCU)/usr/sbin/*
 	$(IPKG_BUILD) $(IDIR_AICCU) $(PACKAGE_DIR)
diff --git a/openwrt/package/aiccu/files/aiccu b/openwrt/package/aiccu/files/aiccu
deleted file mode 100644
index dabafcf3f..000000000
--- a/openwrt/package/aiccu/files/aiccu
+++ /dev/null
@@ -1,21 +0,0 @@
-#!/bin/sh
-
-case "$1" in
-    start)
-	aiccu start	
-	;;
-
-    stop)
-	aiccu stop
-	aiccu stop
-	;;
-
-    restart)
-	$0 stop
-	$0 start
-	;;
-    *)
-	echo "Usage: $0 {start|stop|restart}"
-	exit 1
-	;;
-esac
diff --git a/openwrt/package/aiccu/files/aiccu.init b/openwrt/package/aiccu/files/aiccu.init
new file mode 100644
index 000000000..dabafcf3f
--- /dev/null
+++ b/openwrt/package/aiccu/files/aiccu.init
@@ -0,0 +1,21 @@
+#!/bin/sh
+
+case "$1" in
+    start)
+	aiccu start	
+	;;
+
+    stop)
+	aiccu stop
+	aiccu stop
+	;;
+
+    restart)
+	$0 stop
+	$0 start
+	;;
+    *)
+	echo "Usage: $0 {start|stop|restart}"
+	exit 1
+	;;
+esac
-- 
cgit v1.2.3