From 409f88c3b0863f1e186abef869c50e96960e1c25 Mon Sep 17 00:00:00 2001
From: nico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Sun, 6 Nov 2005 23:08:18 +0000
Subject: add iptables-snmp package (thanks to Nigel Roberts)

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@2360 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 openwrt/package/Config.in                          |  1 +
 openwrt/package/Makefile                           |  1 +
 openwrt/package/iptables-snmp/Config.in            | 11 ++++
 openwrt/package/iptables-snmp/Makefile             | 65 ++++++++++++++++++++++
 .../iptables-snmp/ipkg/iptables-snmp.control       |  5 ++
 5 files changed, 83 insertions(+)
 create mode 100644 openwrt/package/iptables-snmp/Config.in
 create mode 100644 openwrt/package/iptables-snmp/Makefile
 create mode 100644 openwrt/package/iptables-snmp/ipkg/iptables-snmp.control

(limited to 'openwrt')

diff --git a/openwrt/package/Config.in b/openwrt/package/Config.in
index eb31ce8d5..2b59f0569 100644
--- a/openwrt/package/Config.in
+++ b/openwrt/package/Config.in
@@ -70,6 +70,7 @@ source "package/htpdate/Config.in"
 source "package/iproute2/Config.in"
 source "package/iperf/Config.in"
 source "package/ipset/Config.in"
+source "package/iptables-snmp/Config.in"
 source "package/iptraf/Config.in"
 source "package/kismet/Config.in"
 source "package/l2tpd/Config.in"
diff --git a/openwrt/package/Makefile b/openwrt/package/Makefile
index 8cb9ecfbb..e628961e5 100644
--- a/openwrt/package/Makefile
+++ b/openwrt/package/Makefile
@@ -62,6 +62,7 @@ package-$(BR2_PACKAGE_IPKG) += ipkg
 package-$(BR2_COMPILE_IPROUTE2) += iproute2
 package-$(BR2_PACKAGE_IPSET) += ipset
 package-$(BR2_COMPILE_IPTABLES) += iptables
+package-$(BR2_PACKAGE_IPTABLES_SNMP) += iptables-snmp
 package-$(BR2_PACKAGE_IPTRAF) += iptraf
 package-$(BR2_PACKAGE_IRSSI) += irssi
 package-$(BR2_COMPILE_JPEG) += jpeg
diff --git a/openwrt/package/iptables-snmp/Config.in b/openwrt/package/iptables-snmp/Config.in
new file mode 100644
index 000000000..7232abb14
--- /dev/null
+++ b/openwrt/package/iptables-snmp/Config.in
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_IPTABLES_SNMP
+	prompt "iptables-snmp..................... An snmpd plugin to access iptables rules"
+	tristate
+	default m if CONFIG_DEVEL
+	select BR2_PACKAGE_IPTABLES
+	select BR2_PACKAGE_SNMPD
+	help
+	  This is a plugin that makes iptables rules accessable from snmpd.
+	  
+	  http://www.nobiscuit.com/iptables-snmp/
+
diff --git a/openwrt/package/iptables-snmp/Makefile b/openwrt/package/iptables-snmp/Makefile
new file mode 100644
index 000000000..269a109a7
--- /dev/null
+++ b/openwrt/package/iptables-snmp/Makefile
@@ -0,0 +1,65 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=iptables-snmp
+PKG_VERSION:=0.1
+PKG_RELEASE:=1
+PKG_MD5SUM:=8370d2f0c899461a053da491400119d1
+
+PKG_SOURCE_URL:=http://www.nobiscuit.com/iptables-snmp
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,IPTABLES_SNMP,iptables-snmp,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
+	(cd $(PKG_BUILD_DIR); rm -f config.{cache,status}; \
+		$(TARGET_CONFIGURE_OPTS) \
+		CFLAGS="$(TARGET_CFLAGS) " \
+		CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+		./configure \
+			--target=$(GNU_TARGET_NAME) \
+			--host=$(GNU_TARGET_NAME) \
+			--build=$(GNU_HOST_NAME) \
+			--program-prefix="" \
+			--program-suffix="" \
+			--prefix=/usr \
+			--exec-prefix=/usr \
+			--bindir=/usr/bin \
+			--datadir=/usr/share \
+			--includedir=/usr/include \
+			--infodir=/usr/share/info \
+			--libdir=/usr/lib \
+			--libexecdir=/usr/lib \
+			--localstatedir=/var \
+			--mandir=/usr/share/man \
+			--sbindir=/usr/sbin \
+			--sysconfdir=/etc \
+			$(DISABLE_LARGEFILE) \
+			$(DISABLE_NLS) \
+	);
+	touch $@
+
+$(PKG_BUILD_DIR)/.built:
+	rm -rf $(PKG_INSTALL_DIR)
+	mkdir -p $(PKG_INSTALL_DIR)
+	$(MAKE) -C $(PKG_BUILD_DIR) \
+		INSTALL_PREFIX="$(PKG_INSTALL_DIR)" \
+		all install
+	touch $@
+ 
+$(IPKG_IPTABLES_SNMP):
+	install -d -m0755 $(IDIR_IPTABLES_SNMP)/usr/lib
+	cp -fpR $(PKG_INSTALL_DIR)/usr/lib/iptables-snmp.so $(IDIR_IPTABLES_SNMP)/usr/lib
+	$(RSTRIP) $(IDIR_IPTABLES_SNMP)
+	$(IPKG_BUILD) $(IDIR_IPTABLES_SNMP) $(PACKAGE_DIR)
+ 
+mostlyclean:
+	-$(MAKE) -C $(PKG_BUILD_DIR) clean
+	rm $(PKG_BUILD_DIR)/.built
\ No newline at end of file
diff --git a/openwrt/package/iptables-snmp/ipkg/iptables-snmp.control b/openwrt/package/iptables-snmp/ipkg/iptables-snmp.control
new file mode 100644
index 000000000..cd92ffeb5
--- /dev/null
+++ b/openwrt/package/iptables-snmp/ipkg/iptables-snmp.control
@@ -0,0 +1,5 @@
+Package: iptables-snmp
+Priority: optional
+Section: net
+Depends: snmpd
+Description: An snmpd plugin to access iptables rules
\ No newline at end of file
-- 
cgit v1.2.3