From 9d30652149fd745711342cec7ee8574e973ec241 Mon Sep 17 00:00:00 2001
From: mbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Sun, 6 Mar 2005 03:34:52 +0000
Subject: nbd's makefile/menuconfig rewrite

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@307 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 openwrt/toolchain/Makefile | 45 +++++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 45 insertions(+)
 create mode 100644 openwrt/toolchain/Makefile

(limited to 'openwrt/toolchain/Makefile')

diff --git a/openwrt/toolchain/Makefile b/openwrt/toolchain/Makefile
new file mode 100644
index 000000000..0c06fe9ea
--- /dev/null
+++ b/openwrt/toolchain/Makefile
@@ -0,0 +1,45 @@
+# Main makefile for the toolchain
+include $(TOPDIR)/rules.mk
+TARGETS:=sed utils binutils gcc uClibc ipkg-utils
+
+TARGETS_INSTALL:=$(patsubst %,%-install,$(TARGETS))
+TARGETS_CLEAN:=$(patsubst %,%-clean,$(TARGETS))
+
+all: install
+install: $(TARGETS_INSTALL)
+clean: $(TARGETS_CLEAN)
+
+uClibc-prepare: kernel-headers-prepare sed-install utils-install
+binutils-prepare: uClibc-prepare
+gcc-prepare: binutils-install
+uClibc-compile: gcc-prepare
+gcc-install: uClibc-install
+
+$(STAMP_DIR):
+	mkdir -p $(STAMP_DIR)
+
+$(STAGING_DIR):
+	@mkdir -p $(STAGING_DIR)/lib
+	@mkdir -p $(STAGING_DIR)/include
+	@mkdir -p $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)
+	@ln -sf ../lib $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/lib
+
+$(TOOL_BUILD_DIR):
+	@mkdir -p $(TOOL_BUILD_DIR)
+
+%-prepare: $(STAMP_DIR) $(STAGING_DIR) $(TOOL_BUILD_DIR)
+	@[ -f $(STAMP_DIR)/.toolchain_$@ ] || $(MAKE) -C $(patsubst %-prepare,%,$@) prepare
+	@touch $(STAMP_DIR)/.toolchain_$@
+
+%-compile: %-prepare 
+	@[ -f $(STAMP_DIR)/.toolchain_$@ ] || $(MAKE) -C $(patsubst %-compile,%,$@) compile
+	@touch $(STAMP_DIR)/.toolchain_$@
+
+%-install: %-compile
+	@[ -f $(STAMP_DIR)/.toolchain_$@ ] || $(MAKE) -C $(patsubst %-install,%,$@) install
+	@touch $(STAMP_DIR)/.toolchain_$@
+
+%-clean:
+	@$(MAKE) -C $(patsubst %-clean,%,$@) clean
+	@rm -f $(STAMP_DIR)/.toolchain_$(patsubst %-clean,%,$@)-*
+
-- 
cgit v1.2.3