From 6cdf00cc471c60287c0703e06c3ccc14265c731d Mon Sep 17 00:00:00 2001
From: nbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Sun, 5 Jun 2005 22:21:27 +0000
Subject: fix linux kernel build

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1157 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 openwrt/target/linux/linux-2.4/Makefile | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

(limited to 'openwrt/target/linux/linux-2.4/Makefile')

diff --git a/openwrt/target/linux/linux-2.4/Makefile b/openwrt/target/linux/linux-2.4/Makefile
index 9a594b77f..0c9021b1a 100644
--- a/openwrt/target/linux/linux-2.4/Makefile
+++ b/openwrt/target/linux/linux-2.4/Makefile
@@ -213,8 +213,7 @@ $(TARGET_MODULES_DIR):
 source: $(DL_DIR)/$(LINUX_SOURCE)
 prepare: $(LINUX_DIR)/.configured
 compile: $(LINUX_DIR)/.modules_done $(TARGETS)
-	rm -f $(LINUX_DIR)
-	ln -s $(LINUX_BUILD_DIR)/linux-$(LINUX_VERSION) $(LINUX_DIR)
+	ln -sf $(LINUX_BUILD_DIR)/linux-$(LINUX_VERSION) $(LINUX_DIR)
 	$(MAKE) -C $(TOPDIR)/target/linux/package \
 		TARGET_DIR="$(LINUX_TARGET_DIR)" \
 		BUILD_DIR="$(LINUX_BUILD_DIR)" \
-- 
cgit v1.2.3