summaryrefslogtreecommitdiffstats
path: root/target/linux/realtek/patches-2.6.30/002-use-openwrt-toolchain.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/realtek/patches-2.6.30/002-use-openwrt-toolchain.patch')
-rw-r--r--target/linux/realtek/patches-2.6.30/002-use-openwrt-toolchain.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/realtek/patches-2.6.30/002-use-openwrt-toolchain.patch b/target/linux/realtek/patches-2.6.30/002-use-openwrt-toolchain.patch
new file mode 100644
index 000000000..163e66f08
--- /dev/null
+++ b/target/linux/realtek/patches-2.6.30/002-use-openwrt-toolchain.patch
@@ -0,0 +1,11 @@
+--- linux-2.6.30.9.orig/arch/rlx/Makefile 2013-09-05 11:51:23.000000000 +0000
++++ linux-2.6.30.9.orig/arch/rlx/Makefile 2013-09-02 13:49:09.000000000 +0000
+@@ -32,6 +32,8 @@ vmlinux-32 = vmlinux
+ cflags-y := -ffunction-sections
+ cflags-y += $(call cc-option, -mno-check-zero-division)
+ cflags-y += -mabi=32
++cflags-$(CONFIG_ARCH_CPU_RLX4181) += -march=rlx4181
++cflags-$(CONFIG_ARCH_CPU_RLX5281) += -march=rlx5281
+
+ #
+ # GCC uses -G 0 -mabicalls -fpic as default. We don't want PIC in the kernel