summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-2.6.31/998-openwrt_lzma_options.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/generic/patches-2.6.31/998-openwrt_lzma_options.patch')
-rw-r--r--target/linux/generic/patches-2.6.31/998-openwrt_lzma_options.patch44
1 files changed, 44 insertions, 0 deletions
diff --git a/target/linux/generic/patches-2.6.31/998-openwrt_lzma_options.patch b/target/linux/generic/patches-2.6.31/998-openwrt_lzma_options.patch
new file mode 100644
index 000000000..2a38c0bc7
--- /dev/null
+++ b/target/linux/generic/patches-2.6.31/998-openwrt_lzma_options.patch
@@ -0,0 +1,44 @@
+--- a/scripts/Makefile.lib
++++ b/scripts/Makefile.lib
+@@ -228,7 +228,7 @@ cmd_bzip2 = (cat $(filter-out FORCE,$^)
+
+ quiet_cmd_lzma = LZMA $@
+ cmd_lzma = (cat $(filter-out FORCE,$^) | \
+- lzma -9 && $(call size_append, $(filter-out FORCE,$^))) > $@ || \
++ lzma e -lc1 -lp2 -pb2 -eos -si -so && $(call size_append, $(filter-out FORCE,$^))) > $@ || \
+ (rm -f $@ ; false)
+
+ quiet_cmd_lzo = LZO $@
+--- a/scripts/gen_initramfs_list.sh
++++ b/scripts/gen_initramfs_list.sh
+@@ -225,7 +225,7 @@ cpio_list=
+ output="/dev/stdout"
+ output_file=""
+ is_cpio_compressed=
+-compr="gzip -9 -f"
++compr="gzip -9 -f -"
+
+ arg="$1"
+ case "$arg" in
+@@ -239,9 +239,9 @@ case "$arg" in
+ output_file="$1"
+ cpio_list="$(mktemp ${TMPDIR:-/tmp}/cpiolist.XXXXXX)"
+ output=${cpio_list}
+- echo "$output_file" | grep -q "\.gz$" && compr="gzip -9 -f"
+- echo "$output_file" | grep -q "\.bz2$" && compr="bzip2 -9 -f"
+- echo "$output_file" | grep -q "\.lzma$" && compr="lzma -9 -f"
++ echo "$output_file" | grep -q "\.gz$" && compr="gzip -9 -f -"
++ echo "$output_file" | grep -q "\.bz2$" && compr="bzip2 -9 -f -"
++ echo "$output_file" | grep -q "\.lzma$" && compr="lzma e -lc1 -lp2 -pb2 -eos -si -so"
+ echo "$output_file" | grep -q "\.cpio$" && compr="cat"
+ shift
+ ;;
+@@ -292,7 +292,7 @@ if [ ! -z ${output_file} ]; then
+ if [ "${is_cpio_compressed}" = "compressed" ]; then
+ cat ${cpio_tfile} > ${output_file}
+ else
+- (cat ${cpio_tfile} | ${compr} - > ${output_file}) \
++ (cat ${cpio_tfile} | ${compr} > ${output_file}) \
+ || (rm -f ${output_file} ; false)
+ fi
+ [ -z ${cpio_file} ] && rm ${cpio_tfile}