summaryrefslogtreecommitdiffstats
path: root/package/openwrt/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/openwrt/Makefile')
-rw-r--r--package/openwrt/Makefile45
1 files changed, 0 insertions, 45 deletions
diff --git a/package/openwrt/Makefile b/package/openwrt/Makefile
deleted file mode 100644
index 580777a17..000000000
--- a/package/openwrt/Makefile
+++ /dev/null
@@ -1,45 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME := openwrt-utils
-PKG_RELEASE := 2
-PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
-PKG_IPK:=$(PACKAGE_DIR)/$(PKG_NAME)_$(PKG_RELEASE)_$(ARCH).ipk
-PKG_IPK_DIR:=$(PKG_BUILD_DIR)/ipkg
-
-SHARED_INCLUDE:=${shell pwd}/include
-
-libshared-compile libnvram-compile:
- @$(MAKE) -C $(patsubst %-compile,%,$@) compile
-
-libshared-install libnvram-install: libshared-compile libnvram-compile
- @$(MAKE) -C $(patsubst %-install,%,$@) install
-
-libshared-clean libnvram-clean:
- @$(MAKE) -C $(patsubst %-clean,%,$@) clean
-
-$(PKG_IPK_DIR)/sbin/jffs2root: jffs2root.c
- mkdir -p $(PKG_IPK_DIR)/sbin
- $(TARGET_CC) -o $@ $<
-
-$(PKG_IPK): $(PKG_IPK_DIR)/sbin/jffs2root
- $(SCRIPT_DIR)/make-ipkg-dir.sh $(PKG_IPK_DIR) $(PKG_NAME).control $(PKG_RELEASE) $(ARCH)
- $(STRIP) $(PKG_IPK_DIR)/sbin/*
- mkdir -p $(PACKAGE_DIR)
- $(IPKG_BUILD) $(PKG_IPK_DIR) $(PACKAGE_DIR)
-
-$(IPKG_STATE_DIR)/info/$(PKG_NAME).list: $(PKG_IPK)
- $(IPKG) install $<
-
-source:
-prepare:
-compile: prepare libnvram-compile libshared-compile $(PKG_IPK) $(PKG_WLCOMPAT)
- mkdir -p $(STAGING_DIR)/usr/include
- cp -a ./include/* $(STAGING_DIR)/usr/include/
-install: libnvram-install libshared-install \
- $(IPKG_STATE_DIR)/info/$(PKG_NAME).list \
-
-clean: libshared-clean libnvram-clean
- rm -rf $(PKG_BUILD_DIR)
- rm -f $(PKG_IPK)