summaryrefslogtreecommitdiffstats
path: root/package/iptables/iptables.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/iptables/iptables.mk')
-rw-r--r--package/iptables/iptables.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/package/iptables/iptables.mk b/package/iptables/iptables.mk
index 99cf14f27..e343a6122 100644
--- a/package/iptables/iptables.mk
+++ b/package/iptables/iptables.mk
@@ -39,7 +39,7 @@ $(TARGET_DIR)/usr/sbin/iptables: $(IPTABLES_BUILD_DIR)/iptables
$(STRIP) $(TARGET_DIR)/usr/lib/iptables/*.so
rm -rf $(TARGET_DIR)/usr/man
-iptables: $(TARGET_DIR)/usr/sbin/iptables
+iptables: kernel-headers $(TARGET_DIR)/usr/sbin/iptables
iptables-source: $(DL_DIR)/$(IPTABLES_SOURCE)
@@ -49,3 +49,7 @@ iptables-clean:
iptables-dirclean:
rm -rf $(IPTABLES_BUILD_DIR)
+
+ifeq ($(strip $(BR2_PACKAGE_IPTABLES)),y)
+TARGETS+=iptables
+endif