summaryrefslogtreecommitdiffstats
path: root/openwrt
diff options
context:
space:
mode:
Diffstat (limited to 'openwrt')
-rw-r--r--openwrt/package/ebtables/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/openwrt/package/ebtables/Makefile b/openwrt/package/ebtables/Makefile
index 952ac29dd..dae932ea8 100644
--- a/openwrt/package/ebtables/Makefile
+++ b/openwrt/package/ebtables/Makefile
@@ -29,7 +29,13 @@ $(PKG_BUILD_DIR)/.built:
$(IPKG_EBTABLES):
install -d -m0755 $(IDIR_EBTABLES)/etc
install -m0644 $(PKG_BUILD_DIR)/ethertypes $(IDIR_EBTABLES)/etc/
+ install -d -m0755 $(IDIR_EBTABLES)/usr/lib
+ install -m0755 $(PKG_BUILD_DIR)/lib*.so $(IDIR_EBTABLES)/usr/lib/
+ install -d -m0755 $(IDIR_EBTABLES)/usr/lib/ebtables
+ install -m0755 $(PKG_BUILD_DIR)/extensions/*.so $(IDIR_EBTABLES)/usr/lib/ebtables/
install -d -m0755 $(IDIR_EBTABLES)/usr/sbin
install -m0755 $(PKG_BUILD_DIR)/ebtables $(IDIR_EBTABLES)/usr/sbin/
+ install -m0755 $(PKG_BUILD_DIR)/ebtables-save $(IDIR_EBTABLES)/usr/sbin/
+ install -m0755 $(PKG_BUILD_DIR)/ebtables-restore $(IDIR_EBTABLES)/usr/sbin/
$(RSTRIP) $(IDIR_EBTABLES)
$(IPKG_BUILD) $(IDIR_EBTABLES) $(PACKAGE_DIR)