summaryrefslogtreecommitdiffstats
path: root/openwrt/package/speex
diff options
context:
space:
mode:
Diffstat (limited to 'openwrt/package/speex')
-rw-r--r--openwrt/package/speex/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/openwrt/package/speex/Makefile b/openwrt/package/speex/Makefile
index 87a3de967..903966b51 100644
--- a/openwrt/package/speex/Makefile
+++ b/openwrt/package/speex/Makefile
@@ -72,6 +72,8 @@ $(STAGING_DIR)/usr/lib/libspeex.so: $(PKG_BUILD_DIR)/.built
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libspeex.{a,so*} $(STAGING_DIR)/usr/lib/
mkdir -p $(STAGING_DIR)/usr/lib/pkgconfig
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/speex.pc $(STAGING_DIR)/usr/lib/pkgconfig/
+ $(SED) 's,-I$${includedir},,g' $(STAGING_DIR)/usr/lib/pkgconfig/speex.pc
+ $(SED) 's,-L$${libdir},,g' $(STAGING_DIR)/usr/lib/pkgconfig/speex.pc
touch $@
install-dev: $(STAGING_DIR)/usr/lib/libspeex.so