summaryrefslogtreecommitdiffstats
path: root/openwrt/package/lighttpd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'openwrt/package/lighttpd/Makefile')
-rw-r--r--openwrt/package/lighttpd/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/openwrt/package/lighttpd/Makefile b/openwrt/package/lighttpd/Makefile
index 5b53d33a1..d0a88a65a 100644
--- a/openwrt/package/lighttpd/Makefile
+++ b/openwrt/package/lighttpd/Makefile
@@ -65,7 +65,7 @@ $(PKG_BUILD_DIR)/.configured:
(cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
$(TARGET_CONFIGURE_OPTS) \
CFLAGS="$(TARGET_CFLAGS)" \
- CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+ CPPFLAGS="-I$(STAGING_DIR)/usr/include/libxml2 -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
PCRE_LIB="-lpcre" \
PKG_CONFIG_PATH="$(STAGING_DIR)/usr/lib/pkgconfig" \
@@ -111,7 +111,6 @@ $(PKG_BUILD_DIR)/.built:
rm -rf $(PKG_INSTALL_DIR)
mkdir -p $(PKG_INSTALL_DIR)
$(MAKE) -C $(PKG_BUILD_DIR) \
- STAGING_DIR=$(STAGING_DIR) \
DESTDIR="$(PKG_INSTALL_DIR)" \
all install
touch $@