summaryrefslogtreecommitdiffstats
path: root/openwrt/package/libxslt/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'openwrt/package/libxslt/Makefile')
-rw-r--r--openwrt/package/libxslt/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/openwrt/package/libxslt/Makefile b/openwrt/package/libxslt/Makefile
index dc6544810..a187f538c 100644
--- a/openwrt/package/libxslt/Makefile
+++ b/openwrt/package/libxslt/Makefile
@@ -87,6 +87,9 @@ $(STAGING_DIR)/usr/lib/libxslt.so: $(PKG_BUILD_DIR)/.built
$(SED) 's,-I$(STAGING_DIR)/usr/include,,g' $(STAGING_DIR)/usr/bin/xslt-config
$(SED) 's,-L$${libdir},,g' $(STAGING_DIR)/usr/bin/xslt-config
$(SED) 's,-L$(STAGING_DIR)/usr/lib,,g' $(STAGING_DIR)/usr/bin/xslt-config
+ $(SED) 's,-I$${includedir},,g' $(STAGING_DIR)/usr/lib/pkgconfig/libxslt.pc
+ $(SED) 's,-L$${libdir},,g' $(STAGING_DIR)/usr/lib/pkgconfig/libxslt.pc
+ $(SED) 's,-L$(STAGING_DIR)/usr/lib,,g' $(STAGING_DIR)/usr/lib/pkgconfig/libxslt.pc
touch $@
install-dev: $(STAGING_DIR)/usr/lib/libxslt.so