summaryrefslogtreecommitdiffstats
path: root/openwrt/package/gnutls
diff options
context:
space:
mode:
Diffstat (limited to 'openwrt/package/gnutls')
-rw-r--r--openwrt/package/gnutls/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/openwrt/package/gnutls/Makefile b/openwrt/package/gnutls/Makefile
index 525785078..b02199fce 100644
--- a/openwrt/package/gnutls/Makefile
+++ b/openwrt/package/gnutls/Makefile
@@ -108,6 +108,8 @@ $(STAGING_DIR)/usr/lib/libgnutls.so: $(PKG_BUILD_DIR)/.built
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/gnutls{,-extra}.pc $(STAGING_DIR)/usr/lib/pkgconfig/
mkdir -p $(STAGING_DIR)/usr/share/aclocal
$(CP) $(PKG_INSTALL_DIR)/usr/share/aclocal/libgnutls{,-extra}.m4 $(STAGING_DIR)/usr/share/aclocal/
+ $(SED) 's,-I$${includedir},,g' $(STAGING_DIR)/usr/lib/pkgconfig/gnutls{,-extra}.pc
+ $(SED) 's,-L$${libdir},,g' $(STAGING_DIR)/usr/lib/pkgconfig/gnutls{,-extra}.pc
touch $@
install-dev: $(STAGING_DIR)/usr/lib/libgnutls.so