summaryrefslogtreecommitdiffstats
path: root/obsolete-buildroot
diff options
context:
space:
mode:
Diffstat (limited to 'obsolete-buildroot')
-rw-r--r--obsolete-buildroot/make/openwrt.mk4
-rw-r--r--obsolete-buildroot/make/squashfsroot.mk2
2 files changed, 3 insertions, 3 deletions
diff --git a/obsolete-buildroot/make/openwrt.mk b/obsolete-buildroot/make/openwrt.mk
index b8c2c9636..38fa95875 100644
--- a/obsolete-buildroot/make/openwrt.mk
+++ b/obsolete-buildroot/make/openwrt.mk
@@ -202,8 +202,7 @@ openwrt-rootprep:
######################################################################
-openwrt-prune: $(STAGING_DIR)/bin/sstrip openwrt-base
-# -find $(TARGET_DIR) -type f -perm +111 -exec $(STAGING_DIR)/bin/sstrip {} \;
+openwrt-prune: openwrt-base $(STAGING_DIR)/bin/sstrip
# remove unneeded uClibc libs
rm -rf $(TARGET_DIR)/lib/libthread_db*
rm -rf $(TARGET_DIR)/lib/libpthread*
@@ -214,6 +213,7 @@ openwrt-prune: $(STAGING_DIR)/bin/sstrip openwrt-base
rm -f $(TARGET_DIR)/usr/sbin/iptables-save
rm -f $(TARGET_DIR)/usr/sbin/iptables-restore
rm -f $(TARGET_DIR)/usr/sbin/ip6tables
+ -@find $(TARGET_DIR) -type f -perm +111 | xargs $(STAGING_DIR)/bin/sstrip 2>/dev/null || true;
######################################################################
diff --git a/obsolete-buildroot/make/squashfsroot.mk b/obsolete-buildroot/make/squashfsroot.mk
index 3e1b34a83..6c66982e2 100644
--- a/obsolete-buildroot/make/squashfsroot.mk
+++ b/obsolete-buildroot/make/squashfsroot.mk
@@ -36,7 +36,7 @@ squashfs-dirclean:
squashfsroot: squashfs
#-@find $(TARGET_DIR)/lib -type f -name \*.so\* | xargs $(STRIP) --strip-unneeded 2>/dev/null || true;
- -@find $(TARGET_DIR) -type f -perm +111 | xargs $(STAGING_DIR)/bin/sstrip 2>/dev/null || true;
+ #-@find $(TARGET_DIR) -type f -perm +111 | xargs $(STAGING_DIR)/bin/sstrip 2>/dev/null || true;
@rm -rf $(TARGET_DIR)/usr/man
@rm -rf $(TARGET_DIR)/usr/info
#$(SQUASHFS_DIR)/squashfs-tools/mksquashfs -q -D $(SOURCE_DIR)/device_table.txt $(TARGET_DIR) $(IMAGE)