summaryrefslogtreecommitdiffstats
path: root/target/linux/package/openwrt/Makefile
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-08-25 12:11:27 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-08-25 12:11:27 +0000
commit67881f7caf65c39557e3ee656fd9368aec200b65 (patch)
tree6064b2e4c6bb581063901b7405555f03d09ae2c5 /target/linux/package/openwrt/Makefile
parentae808b9458159dad37d247932a386dcfaf4b3b1f (diff)
fix dependency problem
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1752 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/package/openwrt/Makefile')
-rw-r--r--target/linux/package/openwrt/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/target/linux/package/openwrt/Makefile b/target/linux/package/openwrt/Makefile
index 45b33b886..6fb20d622 100644
--- a/target/linux/package/openwrt/Makefile
+++ b/target/linux/package/openwrt/Makefile
@@ -36,12 +36,13 @@ $(IDIR_OPENWRT):
$(SED) s,base-files-arch,base-files-$(BOARD),g $(IDIR_OPENWRT)/CONTROL/control
$(IPKG_OPENWRT): $(IDIR_OPENWRT)
- mkdir -p $(IDIR_OPENWRT)/etc
- cp files/network.overrides.$(BOARD) $(IDIR_OPENWRT)/etc/network.overrides
+ mkdir -p $(IDIR_OPENWRT)/etc/init.d
+ [ -f files/network.overrides.$(BOARD) ] && cp files/network.overrides.$(BOARD) $(IDIR_OPENWRT)/etc/network.overrides
+ [ -f files/S05nvram.$(BOARD) ] && install -m0755 files/S05nvram.$(BOARD) $(IDIR_OPENWRT)/etc/init.d/S05nvram
$(RSTRIP) $(IDIR_OPENWRT)
$(IPKG_BUILD) $(IDIR_OPENWRT) $(PACKAGE_DIR)
-install: $(IPKG_OPENWRT)
+install: compile
$(IPKG) install $(IPKG_OPENWRT)
compile: install-dev $(IPKG_OPENWRT)
install-dev: