summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-3.2/610-MIPS-ath79-openwrt-machines.patch
diff options
context:
space:
mode:
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>2012-01-31 18:37:01 +0000
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>2012-01-31 18:37:01 +0000
commit4bc970ba4f3defb084750172ceea809890e075ba (patch)
tree3b7e20bf2fe7e832980cae9bc537b06dadc79938 /target/linux/ar71xx/patches-3.2/610-MIPS-ath79-openwrt-machines.patch
parent796a085cacd12855c070f95a38bf77332e3673ad (diff)
ar71xx: add support for TP-Link TL-MR11U
Adds support for TL-MR11U, a portable router with very similar hardware to the TL-WR703N and TL-MR3020, but with an onboard 2000mAh battery. Tested, working: All interfaces (Ethernet, 802.11n, USB) WPS & Reset switches (Power appears to be a hardware slider) Ethernet, Wifi, 3G LEDs (Power & charging LEDs hardware controlled) Sysupgrade [juhosg: fix indentations to use TABs instead of spaces, fix 3.2 patch breakage] Signed-off-by: Simon Taylor <simon.taylor.uk@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29972 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/patches-3.2/610-MIPS-ath79-openwrt-machines.patch')
-rw-r--r--target/linux/ar71xx/patches-3.2/610-MIPS-ath79-openwrt-machines.patch26
1 files changed, 19 insertions, 7 deletions
diff --git a/target/linux/ar71xx/patches-3.2/610-MIPS-ath79-openwrt-machines.patch b/target/linux/ar71xx/patches-3.2/610-MIPS-ath79-openwrt-machines.patch
index 9927f6d73..d5204cb08 100644
--- a/target/linux/ar71xx/patches-3.2/610-MIPS-ath79-openwrt-machines.patch
+++ b/target/linux/ar71xx/patches-3.2/610-MIPS-ath79-openwrt-machines.patch
@@ -1,6 +1,6 @@
--- a/arch/mips/ath79/machtypes.h
+++ b/arch/mips/ath79/machtypes.h
-@@ -16,17 +16,79 @@
+@@ -16,17 +16,80 @@
enum ath79_mach_type {
ATH79_MACH_GENERIC = 0,
@@ -40,6 +40,7 @@
+ ATH79_MACH_RB_750, /* MikroTik RouterBOARD 750 */
+ ATH79_MACH_RW2458N, /* Redwave RW2458N */
+ ATH79_MACH_TEW_632BRP, /* TRENDnet TEW-632BRP */
++ ATH79_MACH_TL_MR11U, /* TP-LINK TL-MR11U */
+ ATH79_MACH_TL_MR3020, /* TP-LINK TL-MR3020 */
+ ATH79_MACH_TL_MR3220, /* TP-LINK TL-MR3220 */
+ ATH79_MACH_TL_MR3420, /* TP-LINK TL-MR3420 */
@@ -186,7 +187,7 @@
config ATH79_MACH_PB44
bool "Atheros PB44 reference board"
select SOC_AR71XX
-@@ -54,6 +137,359 @@ config ATH79_MACH_PB44
+@@ -54,6 +137,369 @@ config ATH79_MACH_PB44
Say 'Y' here if you want your kernel to support the
Atheros PB44 reference board.
@@ -419,6 +420,16 @@
+ select ATH79_DEV_LEDS_GPIO
+ select ATH79_DEV_M25P80
+
++config ATH79_MACH_TL_MR11U
++ bool "TP-LINK TL-MR11U support"
++ select SOC_AR933X
++ select ATH79_DEV_ETH
++ select ATH79_DEV_GPIO_BUTTONS
++ select ATH79_DEV_LEDS_GPIO
++ select ATH79_DEV_M25P80
++ select ATH79_DEV_USB
++ select ATH79_DEV_WMAC
++
+config ATH79_MACH_TL_MR3020
+ bool "TP-LINK TL-MR3020 support"
+ select SOC_AR933X
@@ -546,7 +557,7 @@
config ATH79_MACH_UBNT_XM
bool "Ubiquiti Networks XM (rev 1.0) board"
select SOC_AR724X
-@@ -67,6 +503,24 @@ config ATH79_MACH_UBNT_XM
+@@ -67,6 +513,24 @@ config ATH79_MACH_UBNT_XM
Say 'Y' here if you want your kernel to support the
Ubiquiti Networks XM (rev 1.0) board.
@@ -571,7 +582,7 @@
endmenu
config SOC_AR71XX
-@@ -96,10 +550,6 @@ config SOC_AR934X
+@@ -96,10 +560,6 @@ config SOC_AR934X
select PCI_AR724X if PCI
def_bool n
@@ -582,7 +593,7 @@
config ATH79_DEV_AP9X_PCI
select ATH79_PCI_ATH9K_FIXUP
def_bool n
-@@ -110,7 +560,14 @@ config ATH79_DEV_DSA
+@@ -110,7 +570,14 @@ config ATH79_DEV_DSA
config ATH79_DEV_ETH
def_bool n
@@ -598,7 +609,7 @@
def_bool n
config ATH79_DEV_GPIO_BUTTONS
-@@ -135,4 +592,7 @@ config ATH79_NVRAM
+@@ -135,4 +602,7 @@ config ATH79_NVRAM
config ATH79_PCI_ATH9K_FIXUP
def_bool n
@@ -608,7 +619,7 @@
endif
--- a/arch/mips/ath79/Makefile
+++ b/arch/mips/ath79/Makefile
-@@ -36,8 +36,55 @@ obj-$(CONFIG_ATH79_PCI_ATH9K_FIXUP) += p
+@@ -36,8 +36,56 @@ obj-$(CONFIG_ATH79_PCI_ATH9K_FIXUP) += p
#
# Machines
#
@@ -640,6 +651,7 @@
+obj-$(CONFIG_ATH79_MACH_RB750) += mach-rb750.o
+obj-$(CONFIG_ATH79_MACH_RW2458N) += mach-rw2458n.o
+obj-$(CONFIG_ATH79_MACH_TEW_632BRP) += mach-tew-632brp.o
++obj-$(CONFIG_ATH79_MACH_TL_MR11U) += mach-tl-mr11u.o
+obj-$(CONFIG_ATH79_MACH_TL_MR3020) += mach-tl-mr3020.o
+obj-$(CONFIG_ATH79_MACH_TL_MR3X20) += mach-tl-mr3x20.o
+obj-$(CONFIG_ATH79_MACH_TL_WA901ND) += mach-tl-wa901nd.o