summaryrefslogtreecommitdiffstats
path: root/openwrt
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-10-13 12:42:21 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-10-13 12:42:21 +0000
commitf38834b3771af0e4680e92ab23b5a4877f4da7b9 (patch)
tree7bd2518617236cfd0f5fbcd672a2c6ea394c6b23 /openwrt
parent005743ae16e3ceb91fc57cd433558059e81afdf6 (diff)
fix libelf build
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@2103 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt')
-rw-r--r--openwrt/package/libelf/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/openwrt/package/libelf/Makefile b/openwrt/package/libelf/Makefile
index 537c468fd..02ea765b0 100644
--- a/openwrt/package/libelf/Makefile
+++ b/openwrt/package/libelf/Makefile
@@ -27,6 +27,11 @@ $(PKG_BUILD_DIR)/.configured:
CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
mr_cv_target_elf=yes \
+ libelf_64bit=yes \
+ libelf_cv_struct_elf64_ehdr=yes \
+ libelf_cv_type_elf64_addr=no \
+ libelf_cv_struct_elf64_rel=yes \
+ ac_cv_sizeof_long_long=8 \
./configure \
--target=$(GNU_TARGET_NAME) \
--host=$(GNU_TARGET_NAME) \
@@ -49,6 +54,7 @@ $(PKG_BUILD_DIR)/.configured:
$(DISABLE_NLS) \
--enable-shared \
--enable-static \
+ --enable-elf64=yes \
);
touch $@