summaryrefslogtreecommitdiffstats
path: root/openwrt
diff options
context:
space:
mode:
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-02-05 15:38:04 +0000
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-02-05 15:38:04 +0000
commite659c3738ab3ec671a2870a3ae243f08fefcb9ea (patch)
tree7c4321b0fb2b8ef400ea06e91ff605b1b2723db3 /openwrt
parent3013fec2860445447583ea0ab606a0a9e5b9a86b (diff)
Avoid mkdir in postinst, doing it in the Makefile
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@3138 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt')
-rw-r--r--openwrt/package/quagga/Makefile1
-rw-r--r--openwrt/package/quagga/ipkg/quagga.postinst1
2 files changed, 1 insertions, 1 deletions
diff --git a/openwrt/package/quagga/Makefile b/openwrt/package/quagga/Makefile
index e08688c62..a1cc12268 100644
--- a/openwrt/package/quagga/Makefile
+++ b/openwrt/package/quagga/Makefile
@@ -81,6 +81,7 @@ $(IPKG_QUAGGA):
install -d -m0755 $(IDIR_QUAGGA)/etc/init.d/
install -m0755 ./files/quagga.init $(IDIR_QUAGGA)/etc/init.d/quagga
ln -sf quagga $(IDIR_QUAGGA)/etc/init.d/S49quagga
+ install -m0755 $(IDIR_QUAGGA)/var/run/quagga
$(RSTRIP) $(IDIR_QUAGGA)
$(IPKG_BUILD) $(IDIR_QUAGGA) $(PACKAGE_DIR)
diff --git a/openwrt/package/quagga/ipkg/quagga.postinst b/openwrt/package/quagga/ipkg/quagga.postinst
index ff83cfcae..90ffe61e2 100644
--- a/openwrt/package/quagga/ipkg/quagga.postinst
+++ b/openwrt/package/quagga/ipkg/quagga.postinst
@@ -45,5 +45,4 @@ echo "ospfapi 2607/tcp" >>${IPKG_INSTROOT}/etc/services
echo "isisd 2608/tcp" >>${IPKG_INSTROOT}/etc/services
fi
-mkdir -p $dir
chown -R $name:$name $dir