summaryrefslogtreecommitdiffstats
path: root/openwrt
diff options
context:
space:
mode:
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-05-21 11:51:56 +0000
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-05-21 11:51:56 +0000
commite42cd4fa982f6a8a7ee8516bb496e8dda178c711 (patch)
treeb7294a9d8d383a40f76e573f8e0418739907c4f8 /openwrt
parent410597c96a7be848d9fd9c3a91a235aaf27e9fd1 (diff)
tweak ebtables package:
* add /etc/ethertypes (closes: #560), * strip, standardize, * bump release number. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@3811 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt')
-rw-r--r--openwrt/package/ebtables/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/openwrt/package/ebtables/Makefile b/openwrt/package/ebtables/Makefile
index 9abd93a93..d9c1c997d 100644
--- a/openwrt/package/ebtables/Makefile
+++ b/openwrt/package/ebtables/Makefile
@@ -4,14 +4,15 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=ebtables
PKG_VERSION:=2.0.6
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_MD5SUM:=c4559af2366c764c6c42a3fdd40d60d3
PKG_SOURCE_URL:=@SF/ebtables
PKG_SOURCE:=$(PKG_NAME)-v$(PKG_VERSION).tar.gz
-PKG_BUILD_DIR:=$(BUILD_DIR)/ebtables-v$(PKG_VERSION)
PKG_CAT:=zcat
+PKG_BUILD_DIR:=$(BUILD_DIR)/ebtables-v$(PKG_VERSION)
+
include $(TOPDIR)/package/rules.mk
$(eval $(call PKG_template,EBTABLES,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
@@ -26,7 +27,9 @@ $(PKG_BUILD_DIR)/.built:
touch $@
$(IPKG_EBTABLES):
- mkdir -p $(IDIR_EBTABLES)/usr/sbin
- $(CP) $(PKG_BUILD_DIR)/ebtables $(IDIR_EBTABLES)/usr/sbin/
+ install -d -m0755 $(IDIR_EBTABLES)/etc
+ install -m0644 $(PKG_BUILD_DIR)/ethertypes $(IDIR_EBTABLES)/etc/
+ install -d -m0755 $(IDIR_EBTABLES)/usr/sbin
+ install -m0755 $(PKG_BUILD_DIR)/ebtables $(IDIR_EBTABLES)/usr/sbin/
+ $(RSTRIP) $(IDIR_EBTABLES)
$(IPKG_BUILD) $(IDIR_EBTABLES) $(PACKAGE_DIR)
-