summaryrefslogtreecommitdiffstats
path: root/openwrt
diff options
context:
space:
mode:
authorwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-05-27 05:58:23 +0000
committerwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-05-27 05:58:23 +0000
commitdd961778a9ac9fd7c9087ae3474ef17fa874f381 (patch)
treec9b858ac87d6a528ca95e5beead3edc60fcf4cb2 /openwrt
parente89df49f6e22475b5348c7d0156111a982a1b976 (diff)
ipcontrack is a module
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1079 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt')
-rw-r--r--openwrt/package/iptables/kernelconfig.mk12
1 files changed, 6 insertions, 6 deletions
diff --git a/openwrt/package/iptables/kernelconfig.mk b/openwrt/package/iptables/kernelconfig.mk
index 00d2349aa..a0b420f19 100644
--- a/openwrt/package/iptables/kernelconfig.mk
+++ b/openwrt/package/iptables/kernelconfig.mk
@@ -17,23 +17,23 @@ ext-$(CONFIG_IP_NF_MATCH_LENGTH) += length
ext-$(CONFIG_IP_NF_MATCH_TTL) += ttl
ext-$(CONFIG_IP_NF_MATCH_TCPMSS) += tcpmss
ext-$(CONFIG_IP_NF_MATCH_HELPER) += helper
-ext-$(CONFIG_IP_NF_MATCH_STATE) += state
-ext-$(CONFIG_IP_NF_MATCH_CONNTRACK) += conntrack
+#ext-$(CONFIG_IP_NF_MATCH_STATE) += state
+#ext-$(CONFIG_IP_NF_MATCH_CONNTRACK) += conntrack
ext-$(CONFIG_IP_NF_MATCH_UNCLEAN) += unclean
ext-$(CONFIG_IP_NF_MATCH_OWNER) += owner
ext-$(CONFIG_IP_NF_MATCH_PHYSDEV) += physdev
ext-$(CONFIG_IP_NF_MATCH_LAYER7) += layer7
-ext-$(CONFIG_IP_NF_TARGET_MASQUERADE) += MASQUERADE
+#ext-$(CONFIG_IP_NF_TARGET_MASQUERADE) += MASQUERADE
ext-$(CONFIG_IP_NF_TARGET_REDIRECT) += REDIRECT
ext-$(CONFIG_IP_NF_TARGET_REJECT) += REJECT
ext-$(CONFIG_IP_NF_TARGET_TOS) += TOS
ext-$(CONFIG_IP_NF_TARGET_ECN) += ECN
ext-$(CONFIG_IP_NF_TARGET_DSCP) += DSCP
ext-$(CONFIG_IP_NF_TARGET_MARK) += MARK
-ext-$(CONFIG_IP_NF_TARGET_LOG) += LOG
+#ext-$(CONFIG_IP_NF_TARGET_LOG) += LOG
ext-$(CONFIG_IP_NF_TARGET_ULOG) += ULOG
-ext-$(CONFIG_IP_NF_TARGET_TCPMSS) += TCPMSS
+#ext-$(CONFIG_IP_NF_TARGET_TCPMSS) += TCPMSS
# add extensions that don't depend on kernel config
ext-m += TTL
-ext-y += icmp standard tcp udp
+ext-y += icmp standard tcp udp state MASQUERADE conntrack TCPMSS LOG