summaryrefslogtreecommitdiffstats
path: root/openwrt
diff options
context:
space:
mode:
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-04-08 15:40:28 +0000
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-04-08 15:40:28 +0000
commitb42bd7e8495f5e1901c816c40aeeb2b7b9738d81 (patch)
treeb8b7fe595ca566db4b171515bbb94f9387f8dca6 /openwrt
parent8994621a7af3f4143f36c14525d998f0866e0591 (diff)
Remove .la libtool library files
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@584 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt')
-rw-r--r--openwrt/package/glib/Makefile1
-rw-r--r--openwrt/package/pcre/ipkg/rules2
-rw-r--r--openwrt/package/popt/ipkg/rules2
3 files changed, 5 insertions, 0 deletions
diff --git a/openwrt/package/glib/Makefile b/openwrt/package/glib/Makefile
index c3a0e6a67..64646c41c 100644
--- a/openwrt/package/glib/Makefile
+++ b/openwrt/package/glib/Makefile
@@ -80,6 +80,7 @@ $(STAGING_DIR)/lib/libglib.so: $(PKG_BUILD_DIR)/libglib.so
DESTDIR="$(STAGING_DIR)" \
install
cp $(PKG_BUILD_DIR)/glibconfig-sysdefs.h $(STAGING_DIR)/usr/include/glib-1.2/
+ rm -f $(STAGING_DIR)/usr/lib/libg{lib,module,thread}.la
$(PKG_IPK): $(STAGING_DIR)/lib/libglib.so
mkdir -p $(PACKAGE_DIR)
diff --git a/openwrt/package/pcre/ipkg/rules b/openwrt/package/pcre/ipkg/rules
index c5d1d335b..ead5116d8 100644
--- a/openwrt/package/pcre/ipkg/rules
+++ b/openwrt/package/pcre/ipkg/rules
@@ -78,6 +78,8 @@ $(INSTALL_DIR)/usr/include/pcre.h: .stamp-built
DESTDIR="$(INSTALL_DIR)" \
install
+ rm -f $(INSTALL_DIR)/usr/lib/libpcre*.la
+
configure: .stamp-configured
diff --git a/openwrt/package/popt/ipkg/rules b/openwrt/package/popt/ipkg/rules
index 2ab310b2e..7a615a5f2 100644
--- a/openwrt/package/popt/ipkg/rules
+++ b/openwrt/package/popt/ipkg/rules
@@ -72,6 +72,8 @@ $(INSTALL_DIR)/usr/include/popt.h: .stamp-built
DESTDIR="$(INSTALL_DIR)" \
install
+ rm -f $(INSTALL_DIR)/usr/lib/libpopt.la
+
configure: .stamp-configured