summaryrefslogtreecommitdiffstats
path: root/openwrt
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-10-17 13:03:22 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-10-17 13:03:22 +0000
commit7d97448a6ee04e47d862cb9aefe3cb6d306b90de (patch)
tree3901f381c05f5deafd4f85168b06823ed37086b6 /openwrt
parent73d4408303f245cbc6a1d4f11446ba49d97e3c39 (diff)
add endian override for mips (big-endian) arch
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@2134 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt')
-rw-r--r--openwrt/package/libnet/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/openwrt/package/libnet/Makefile b/openwrt/package/libnet/Makefile
index 97b228e98..1673c0de1 100644
--- a/openwrt/package/libnet/Makefile
+++ b/openwrt/package/libnet/Makefile
@@ -16,6 +16,11 @@ PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
include $(TOPDIR)/package/rules.mk
+ENDIAN:=lil
+ifeq ($(ARCH),mips)
+ENDIAN:=big
+endif
+
$(eval $(call PKG_template,LIBNET,libnet,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
$(PKG_BUILD_DIR)/.configured:
@@ -31,7 +36,7 @@ $(PKG_BUILD_DIR)/.configured:
LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
ac_libnet_have_pf_packet=yes \
ac_cv_lbl_unaligned_fail=no \
- ac_cv_libnet_endianess=lil \
+ ac_cv_libnet_endianess=$(ENDIAN) \
./configure \
--target=$(GNU_TARGET_NAME) \
--host=$(GNU_TARGET_NAME) \