summaryrefslogtreecommitdiffstats
path: root/openwrt
diff options
context:
space:
mode:
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-04-02 01:25:05 +0000
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-04-02 01:25:05 +0000
commit7814b06349c34a8558a0c04028143fc10e8a641e (patch)
treea03e1e692176b319f644b6a731c41712fa82d5da /openwrt
parentcd5f1bd4a1f66c51416e9a9b22dfa19159ea97b7 (diff)
fix kmod-fuse build on 2.4
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@3577 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt')
-rw-r--r--openwrt/target/linux/package/fuse/patches/101-kmod_build.patch6
1 files changed, 4 insertions, 2 deletions
diff --git a/openwrt/target/linux/package/fuse/patches/101-kmod_build.patch b/openwrt/target/linux/package/fuse/patches/101-kmod_build.patch
index feed52aef..e541d4714 100644
--- a/openwrt/target/linux/package/fuse/patches/101-kmod_build.patch
+++ b/openwrt/target/linux/package/fuse/patches/101-kmod_build.patch
@@ -25,13 +25,15 @@ diff -Nur fuse-2.5.2/kernel/Makefile.in fuse-2.5.2.patched/kernel/Makefile.in
fuse_headers = fuse_i.h fuse_kernel.h
dev.o: $(fuse_headers)
-@@ -78,6 +63,16 @@
+@@ -78,6 +63,18 @@
file.o: $(fuse_headers)
inode.o: $(fuse_headers)
+EXTRA_CFLAGS += -DFUSE_VERSION=\"$(VERSION)\"
+
-+obj-m := $(fuse_objs)
++O_TARGET := fuse.o
++
++obj-y := $(fuse_objs)
+obj-m := $(O_TARGET)
+
+-include $(TOPDIR)/Rules.make