summaryrefslogtreecommitdiffstats
path: root/openwrt
diff options
context:
space:
mode:
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-05-15 07:14:09 +0000
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-05-15 07:14:09 +0000
commit5ac6e3ebb9ca3cb393f445c6710cbdfc9fa56a68 (patch)
tree010cffee54d6a450160e02918d72e556542ddb54 /openwrt
parentcd8d40b6624a51704b922432a3ad7ba82bc7c2d7 (diff)
add matrixtunnel package (thanks to Lorenz Schori).
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@3779 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt')
-rw-r--r--openwrt/package/Config.in1
-rw-r--r--openwrt/package/Makefile1
-rw-r--r--openwrt/package/depend.mk1
-rw-r--r--openwrt/package/matrixtunnel/Config.in10
-rw-r--r--openwrt/package/matrixtunnel/Makefile69
-rw-r--r--openwrt/package/matrixtunnel/ipkg/matrixtunnel.control5
6 files changed, 87 insertions, 0 deletions
diff --git a/openwrt/package/Config.in b/openwrt/package/Config.in
index 3d250ce91..8863994bd 100644
--- a/openwrt/package/Config.in
+++ b/openwrt/package/Config.in
@@ -113,6 +113,7 @@ source "package/lighttpd/Config.in"
source "package/linux-atm/Config.in"
source "package/macchanger/Config.in"
source "package/maradns/Config.in"
+source "package/matrixtunnel/Config.in"
source "package/miau/Config.in"
source "package/mini_httpd/Config.in"
source "package/mini_sendmail/Config.in"
diff --git a/openwrt/package/Makefile b/openwrt/package/Makefile
index 7782afc57..89e0bab9e 100644
--- a/openwrt/package/Makefile
+++ b/openwrt/package/Makefile
@@ -140,6 +140,7 @@ package-$(BR2_PACKAGE_MACCHANGER) += macchanger
package-$(BR2_PACKAGE_MADPLAY) += madplay
package-$(BR2_PACKAGE_MARADNS) += maradns
package-$(BR2_COMPILE_MATRIXSSL) += matrixssl
+package-$(BR2_PACKAGE_MATRIXTUNNEL) += matrixtunnel
package-$(BR2_PACKAGE_MGETTY) += mgetty
package-$(BR2_PACKAGE_MIAU) += miau
package-$(BR2_PACKAGE_MIAX) += miax
diff --git a/openwrt/package/depend.mk b/openwrt/package/depend.mk
index 1903616e1..35e81b18b 100644
--- a/openwrt/package/depend.mk
+++ b/openwrt/package/depend.mk
@@ -46,6 +46,7 @@ libxslt-compile: libxml2-compile
lighttpd-compile: openssl-compile pcre-compile libxml2-compile sqlite-compile
logrotate-compile: popt-compile
madplay-compile: libid3tag-compile libmad-compile
+matrixtunnel-compile: matrixssl-compile
miax-compile: bluez-libs-compile
miredo-compile: uclibc++-compile
monit-compile: openssl-compile
diff --git a/openwrt/package/matrixtunnel/Config.in b/openwrt/package/matrixtunnel/Config.in
new file mode 100644
index 000000000..1738ce301
--- /dev/null
+++ b/openwrt/package/matrixtunnel/Config.in
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_MATRIXTUNNEL
+ prompt "matrixtunnel...................... stunnel based on matrixssl"
+ tristate
+ default m if CONFIG_DEVEL
+ select BR2_PACKAGE_LIBMATRIXSSL
+ help
+ matrixtunnel is a stripped down version of stunnel
+ based on matrixssl library
+
+ Depends: libmatrixssl
diff --git a/openwrt/package/matrixtunnel/Makefile b/openwrt/package/matrixtunnel/Makefile
new file mode 100644
index 000000000..ea42b1e8d
--- /dev/null
+++ b/openwrt/package/matrixtunnel/Makefile
@@ -0,0 +1,69 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=matrixtunnel
+PKG_VERSION:=0.1
+PKG_RELEASE:=1
+PKG_MD5SUM:=ffbbe0c50cc1863f6080aca302f7e2c8
+
+PKG_SOURCE_URL:=http://znerol.ch/files
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,MATRIXTUNNEL,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
+ (cd $(PKG_BUILD_DIR); \
+ $(TARGET_CONFIGURE_OPTS) \
+ CFLAGS="$(TARGET_CFLAGS)" \
+ CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+ LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
+ ./configure \
+ --target=$(GNU_TARGET_NAME) \
+ --host=$(GNU_TARGET_NAME) \
+ --build=$(GNU_HOST_NAME) \
+ --program-prefix="" \
+ --program-suffix="" \
+ --prefix=/usr \
+ --exec-prefix=/usr \
+ --bindir=/usr/sbin \
+ --datadir=/usr/share \
+ --includedir=/usr/include \
+ --infodir=/usr/share/info \
+ --libdir=/usr/lib \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --mandir=/usr/share/man \
+ --sbindir=/usr/sbin \
+ --sysconfdir=/etc \
+ $(DISABLE_LARGEFILE) \
+ $(DISABLE_NLS) \
+ --without-libiconv-prefix \
+ --without-libintl-prefix \
+ --with-matrixssl-src=$(BUILD_DIR)/matrixssl \
+ );
+ touch $@
+
+$(PKG_BUILD_DIR)/.built:
+ rm -rf $(PKG_INSTALL_DIR)
+ mkdir -p $(PKG_INSTALL_DIR)
+ $(MAKE) -C $(PKG_BUILD_DIR)/src \
+ DESTDIR="$(PKG_INSTALL_DIR)" \
+ all install
+ touch $@
+
+$(IPKG_MATRIXTUNNEL):
+ install -d -m0755 $(IDIR_MATRIXTUNNEL)/usr/sbin
+ $(CP) $(PKG_INSTALL_DIR)/usr/sbin/matrixtunnel $(IDIR_MATRIXTUNNEL)/usr/sbin/
+ $(RSTRIP) $(IDIR_MATRIXTUNNEL)
+ $(IPKG_BUILD) $(IDIR_MATRIXTUNNEL) $(PACKAGE_DIR)
+
+mostlyclean:
+ $(MAKE) -C $(PKG_BUILD_DIR) clean
+ rm -f $(PKG_BUILD_DIR)/.built
diff --git a/openwrt/package/matrixtunnel/ipkg/matrixtunnel.control b/openwrt/package/matrixtunnel/ipkg/matrixtunnel.control
new file mode 100644
index 000000000..2d022e9ba
--- /dev/null
+++ b/openwrt/package/matrixtunnel/ipkg/matrixtunnel.control
@@ -0,0 +1,5 @@
+Package: matrixtunnel
+Priority: optional
+Section: net
+Description: stunnel based on matrixssl
+Depends: libmatrixssl