summaryrefslogtreecommitdiffstats
path: root/openwrt
diff options
context:
space:
mode:
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-05-18 08:32:07 +0000
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-05-18 08:32:07 +0000
commit59e10adc2d35e497529f191fc60428591cfd6265 (patch)
tree666ec7aab1f32d0620ddc3b5b1d72f3b0a287824 /openwrt
parentfaa5f28154c166f7b900d6ace32382a4c5851667 (diff)
update busybox to v1.1.3, remove passwd_salt patch (fixed upstream).
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@3794 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt')
-rw-r--r--openwrt/package/busybox/Makefile4
-rw-r--r--openwrt/package/busybox/patches/230-passwd_salt.patch13
2 files changed, 2 insertions, 15 deletions
diff --git a/openwrt/package/busybox/Makefile b/openwrt/package/busybox/Makefile
index 35f954b93..83c74ff4c 100644
--- a/openwrt/package/busybox/Makefile
+++ b/openwrt/package/busybox/Makefile
@@ -13,11 +13,11 @@ PKG_SOURCE:=$(PKG_NAME)-snapshot.tar.bz2
PKG_SOURCE_URL:=http://www.busybox.net/downloads/snapshots
PKG_MD5SUM:=x
else
-PKG_VERSION:=1.1.2
+PKG_VERSION:=1.1.3
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://www.busybox.net/downloads
-PKG_MD5SUM:=0b5d78072302fe687407956537bdb9e3
+PKG_MD5SUM:=19a0b475169335f17e421cf644616fe7
endif
PKG_CAT:=bzcat
diff --git a/openwrt/package/busybox/patches/230-passwd_salt.patch b/openwrt/package/busybox/patches/230-passwd_salt.patch
deleted file mode 100644
index 0322a9843..000000000
--- a/openwrt/package/busybox/patches/230-passwd_salt.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- busybox-1.00/loginutils/passwd.c 2006-03-26 06:07:37 -05:00
-+++ busybox-1.00/loginutils/passwd.c 2006-03-26 06:09:03 -05:00
-@@ -386,7 +386,9 @@
- bzero(orig, sizeof(orig));
-
- if (algo == 1) {
-- cp = pw_encrypt(pass, "$1$");
-+ char salt[6]="$1$\0\0\0";
-+ memcpy(salt+3,crypt_make_salt(),3);
-+ cp = pw_encrypt(pass, salt);
- } else
- cp = pw_encrypt(pass, crypt_make_salt());
- bzero(pass, sizeof pass);